{"answers":{"affected":"4 open source packages ship an affected version, including puppet. It affects 3 products.","exploited":"There is no known exploitation of CVE-2013-1655 in the wild and no public exploit code.","fix":"Upgrade puppet to a fixed version for your release line: 2.7.21 or 3.1.1.","what":"CVE-2013-1655 is a high-severity unsafe deserialization vulnerability in Puppet Puppet Enterprise, published on 20 Mar 2013. It can be exploited over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2013-1655 and fix it if it is affected.\n\nWhat it is: CVE-2013-1655 is a high-severity unsafe deserialization vulnerability in Puppet Puppet Enterprise, published on 20 Mar 2013. It can be exploited over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2013-1655 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- puppet (RubyGems): affected from 2.7.0; fixed in 2.7.21\n- puppet (RubyGems): affected from 2.7.0; fixed in 2.7.21\n- puppet (RubyGems): affected from 3.1.0; fixed in 3.1.1\n- puppet (RubyGems): affected from 3.1.0; fixed in 3.1.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2013-1655/ (Markdown: https://insights.sbomify.com/CVE-2013-1655/index.md)","id":"CVE-2013-1655","markdown":"https://insights.sbomify.com/CVE-2013-1655/index.md","name":"CVE-2013-1655","record":{"aliases":["DEBIAN-CVE-2013-1655","GHSA-574q-fxfj-wv6h"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Puppet configuration management","requires_auth":"unknown","summary":"Remote attackers can execute arbitrary code on Puppet servers via serialized attributes, requiring immediate upgrades.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"puppet","vendor":"puppet"},{"product":"puppet_enterprise","vendor":"puppet"},{"product":"puppet","vendor":"puppetlabs"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"AV:N/AC:L/Au:N/C:P/I:P/A:P","version":"2.0"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"Puppet 2.7.x before 2.7.21 and 3.1.x before 3.1.1, when running Ruby 1.9.3 or later, allows remote attackers to execute arbitrary code via vectors related to \"serialized attributes.\"","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Puppet Improper Input Validation vulnerability","id":"CVE-2013-1655","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":"puppet:puppet_enterprise","products":["puppet:puppet_enterprise"],"type":"deserialization","year":"2013"},"n_packages":4,"n_references":7,"next":{"headline":"Spree Improper Input Validation vulnerability","id":"CVE-2013-1656"},"packages":[{"ecosystem":"RubyGems","fixed":["2.7.21"],"introduced":["2.7.0"],"last_affected":[],"package":"puppet","purl":null,"source":"GHSA-574q-fxfj-wv6h"},{"ecosystem":"RubyGems","fixed":["2.7.21"],"introduced":["2.7.0"],"last_affected":[],"package":"puppet","purl":"pkg:gem/puppet","source":"GHSA-574q-fxfj-wv6h"},{"ecosystem":"RubyGems","fixed":["3.1.1"],"introduced":["3.1.0"],"last_affected":[],"package":"puppet","purl":null,"source":"GHSA-574q-fxfj-wv6h"},{"ecosystem":"RubyGems","fixed":["3.1.1"],"introduced":["3.1.0"],"last_affected":[],"package":"puppet","purl":"pkg:gem/puppet","source":"GHSA-574q-fxfj-wv6h"}],"prev":{"headline":"Weak cryptography in n/a","id":"CVE-2013-1654"},"products":["n/a"],"published":"2013-03-20","related":[{"cvss_score":9.8,"headline":"Puppet Improper Access Control","id":"CVE-2016-2785","kev_date_added":null,"published":"2016-06-10"},{"cvss_score":8.8,"headline":"SQL injection in Puppet DB","id":"CVE-2021-27021","kev_date_added":null,"published":"2021-07-20"},{"cvss_score":8.8,"headline":"Privilege escalation in Puppet Enterprise and Puppet Agent","id":"CVE-2018-6513","kev_date_added":null,"published":"2018-06-11"},{"cvss_score":7.8,"headline":"Privilege escalation in Puppet Agent","id":"CVE-2018-6514","kev_date_added":null,"published":"2018-06-11"},{"cvss_score":7.8,"headline":"Code injection in Puppet Agent","id":"CVE-2018-6515","kev_date_added":null,"published":"2018-06-11"},{"cvss_score":6.9,"headline":"Puppet Privilege Escallation","id":"CVE-2012-1053","kev_date_added":null,"published":"2012-05-29"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can execute arbitrary code on Puppet servers via serialized attributes, requiring immediate upgrades.","url":"https://insights.sbomify.com/CVE-2013-1655/"}