# CVE-2013-1655: Puppet Improper Input Validation vulnerability

> Remote attackers can execute arbitrary code on Puppet servers via serialized attributes, requiring immediate upgrades.

- **Severity:** High 7.5 (`AV:N/AC:L/Au:N/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not stated
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Mar 2013
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2013-1655, GHSA-574q-fxfj-wv6h

## What is CVE-2013-1655?

CVE-2013-1655 is a high-severity unsafe deserialization vulnerability in Puppet Puppet Enterprise, published on 20 Mar 2013. It can be exploited over the network, with no action from the victim.

### Official description

Puppet 2.7.x before 2.7.21 and 3.1.x before 3.1.1, when running Ruby 1.9.3 or later, allows remote attackers to execute arbitrary code via vectors related to "serialized attributes."

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2013-1655?

4 open source packages ship an affected version, including puppet. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `puppet` | RubyGems | From 2.7.0 | 2.7.21 |
| `puppet` | RubyGems | From 2.7.0 | 2.7.21 |
| `puppet` | RubyGems | From 3.1.0 | 3.1.1 |
| `puppet` | RubyGems | From 3.1.0 | 3.1.1 |

Products: Puppet Puppet, Puppet Puppet Enterprise, Puppetlabs Puppet.

## How do I fix CVE-2013-1655?

Upgrade puppet to a fixed version for your release line: 2.7.21 or 3.1.1.

## Is CVE-2013-1655 being exploited?

There is no known exploitation of CVE-2013-1655 in the wild and no public exploit code.

## Other vulnerabilities in Puppet Puppet Enterprise

- [CVE-2016-2785](https://insights.sbomify.com/CVE-2016-2785/): Puppet Improper Access Control (critical 9.8)
- [CVE-2021-27021](https://insights.sbomify.com/CVE-2021-27021/): SQL injection in Puppet DB (high 8.8)
- [CVE-2018-6513](https://insights.sbomify.com/CVE-2018-6513/): Privilege escalation in Puppet Enterprise and Puppet Agent (high 8.8)
- [CVE-2018-6514](https://insights.sbomify.com/CVE-2018-6514/): Privilege escalation in Puppet Agent (high 7.8)
- [CVE-2018-6515](https://insights.sbomify.com/CVE-2018-6515/): Code injection in Puppet Agent (high 7.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2013-1655 and fix it if it is affected.

What it is: CVE-2013-1655 is a high-severity unsafe deserialization vulnerability in Puppet Puppet Enterprise, published on 20 Mar 2013. It can be exploited over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2013-1655 in the wild and no public exploit code.

Affected packages and fixed versions:
- puppet (RubyGems): affected from 2.7.0; fixed in 2.7.21
- puppet (RubyGems): affected from 2.7.0; fixed in 2.7.21
- puppet (RubyGems): affected from 3.1.0; fixed in 3.1.1
- puppet (RubyGems): affected from 3.1.0; fixed in 3.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2013-1655/ (Markdown: https://insights.sbomify.com/CVE-2013-1655/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2013-1655
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2013-1655
- OSV: https://osv.dev/vulnerability/CVE-2013-1655

---
From sbomify Insights: https://insights.sbomify.com/CVE-2013-1655/
Summaries are generated and may contain mistakes; the official description above is the record.
