{"answers":{"affected":"2 open source packages ship an affected version, including spree. It affects 1 product.","exploited":"There is no known exploitation of CVE-2013-1656 in the wild and no public exploit code.","fix":"Upgrade spree to 2.0.0.rc1 or later.","what":"CVE-2013-1656 is a medium-severity code injection vulnerability in n/a, published on 8 Mar 2013. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2013-1656 and fix it if it is affected.\n\nWhat it is: CVE-2013-1656 is a medium-severity code injection vulnerability in n/a, published on 8 Mar 2013. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2013-1656 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- spree (RubyGems): affected from 1.0.0; fixed in 2.0.0.rc1\n- spree (RubyGems): affected from 1.0.0; fixed in 2.0.0.rc1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2013-1656/ (Markdown: https://insights.sbomify.com/CVE-2013-1656/index.md)","id":"CVE-2013-1656","markdown":"https://insights.sbomify.com/CVE-2013-1656/index.md","name":"CVE-2013-1656","record":{"aliases":["GHSA-jxx8-v83v-rhw3"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"E-commerce platform","requires_auth":"high_privilege","summary":"Authenticated administrators can execute arbitrary commands via unsafe constantize usage in Spree Commerce admin controllers.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"spree","vendor":"spreecommerce"}],"cvss":{"score":4.3,"severity":"medium","source":"nvd","vector":"AV:N/AC:M/Au:N/C:N/I:P/A:N","version":"2.0"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"Spree Commerce 1.0.x through 1.3.2 allows remote authenticated administrators to instantiate arbitrary Ruby objects and execute arbitrary commands via the (1) payment_method parameter to core/app/controllers/spree/admin/payment_methods_controller.rb; and the (2) promotion_action parameter to promotion_actions_controller.rb, (3) promotion_rule parameter to promotion_rules_controller.rb, and (4) calculator_type parameter to promotions_controller.rb in promo/app/controllers/spree/admin/, related to unsafe use of the constantize function.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Spree Improper Input Validation vulnerability","id":"CVE-2013-1656","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"code_injection","year":"2013"},"n_packages":2,"n_references":3,"next":{"headline":"Memory corruption in n/a","id":"CVE-2013-1659"},"packages":[{"ecosystem":"RubyGems","fixed":["2.0.0.rc1"],"introduced":["1.0.0"],"last_affected":[],"package":"spree","purl":null,"source":"GHSA-jxx8-v83v-rhw3"},{"ecosystem":"RubyGems","fixed":["2.0.0.rc1"],"introduced":["1.0.0"],"last_affected":[],"package":"spree","purl":"pkg:gem/spree","source":"GHSA-jxx8-v83v-rhw3"}],"prev":{"headline":"Puppet Improper Input Validation vulnerability","id":"CVE-2013-1655"},"products":["n/a"],"published":"2013-03-08","related":[{"cvss_score":10,"headline":"Spreecommerce \u003c 0.60.2 Search Parameter RCE","id":"CVE-2011-10019","kev_date_added":null,"published":"2025-08-13"},{"cvss_score":9.3,"headline":"Spreecommerce \u003c 0.50.x API RCE","id":"CVE-2011-10026","kev_date_added":null,"published":"2025-08-20"},{"cvss_score":7.7,"headline":"Unauthenticated Spree Commerce users can view completed guest orders by Order ID","id":"CVE-2026-25757","kev_date_added":null,"published":"2026-02-06"},{"cvss_score":7.7,"headline":"Spree allows unauthenticated users can access all guest addresses","id":"CVE-2026-25758","kev_date_added":null,"published":"2026-02-06"},{"cvss_score":7.7,"headline":"Authorization bypass in Spree","id":"CVE-2020-26223","kev_date_added":null,"published":"2020-11-13"},{"cvss_score":7.5,"headline":"Spree API has Unauthenticated IDOR - Guest Address","id":"CVE-2026-22589","kev_date_added":null,"published":"2026-01-10"},{"cvss_score":6.5,"headline":"Spree API has Authenticated Insecure Direct Object Reference (IDOR) via Order Modification","id":"CVE-2026-22588","kev_date_added":null,"published":"2026-01-08"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Authenticated administrators can execute arbitrary commands via unsafe constantize usage in Spree Commerce admin controllers.","url":"https://insights.sbomify.com/CVE-2013-1656/"}