# CVE-2013-1656: Spree Improper Input Validation vulnerability

> Authenticated administrators can execute arbitrary commands via unsafe constantize usage in Spree Commerce admin controllers.

- **Severity:** Medium 4.3 (`AV:N/AC:M/Au:N/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Mar 2013
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-jxx8-v83v-rhw3

## What is CVE-2013-1656?

CVE-2013-1656 is a medium-severity code injection vulnerability in n/a, published on 8 Mar 2013. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Spree Commerce 1.0.x through 1.3.2 allows remote authenticated administrators to instantiate arbitrary Ruby objects and execute arbitrary commands via the (1) payment_method parameter to core/app/controllers/spree/admin/payment_methods_controller.rb; and the (2) promotion_action parameter to promotion_actions_controller.rb, (3) promotion_rule parameter to promotion_rules_controller.rb, and (4) calculator_type parameter to promotions_controller.rb in promo/app/controllers/spree/admin/, related to unsafe use of the constantize function.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2013-1656?

2 open source packages ship an affected version, including spree. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `spree` | RubyGems | From 1.0.0 | 2.0.0.rc1 |
| `spree` | RubyGems | From 1.0.0 | 2.0.0.rc1 |

Products: Spreecommerce Spree.

## How do I fix CVE-2013-1656?

Upgrade spree to 2.0.0.rc1 or later.

## Is CVE-2013-1656 being exploited?

There is no known exploitation of CVE-2013-1656 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2011-10019](https://insights.sbomify.com/CVE-2011-10019/): Spreecommerce < 0.60.2 Search Parameter RCE (critical 10.0)
- [CVE-2011-10026](https://insights.sbomify.com/CVE-2011-10026/): Spreecommerce < 0.50.x API RCE (critical 9.3)
- [CVE-2026-25757](https://insights.sbomify.com/CVE-2026-25757/): Unauthenticated Spree Commerce users can view completed guest orders by Order ID (high 7.7)
- [CVE-2026-25758](https://insights.sbomify.com/CVE-2026-25758/): Spree allows unauthenticated users can access all guest addresses (high 7.7)
- [CVE-2020-26223](https://insights.sbomify.com/CVE-2020-26223/): Authorization bypass in Spree (high 7.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2013-1656 and fix it if it is affected.

What it is: CVE-2013-1656 is a medium-severity code injection vulnerability in n/a, published on 8 Mar 2013. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2013-1656 in the wild and no public exploit code.

Affected packages and fixed versions:
- spree (RubyGems): affected from 1.0.0; fixed in 2.0.0.rc1
- spree (RubyGems): affected from 1.0.0; fixed in 2.0.0.rc1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2013-1656/ (Markdown: https://insights.sbomify.com/CVE-2013-1656/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2013-1656
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2013-1656
- OSV: https://osv.dev/vulnerability/CVE-2013-1656

---
From sbomify Insights: https://insights.sbomify.com/CVE-2013-1656/
Summaries are generated and may contain mistakes; the official description above is the record.
