{"answers":{"affected":"4 open source packages ship an affected version, including dragonfly. It affects 1 product.","exploited":"There is no known exploitation of CVE-2013-1756 in the wild and no public exploit code.","fix":"Upgrade dragonfly to a fixed version for your release line: 0.8.6 or 0.9.13.","what":"CVE-2013-1756 is a high-severity code injection vulnerability in n/a, published on 9 Jun 2014. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2013-1756 and fix it if it is affected.\n\nWhat it is: CVE-2013-1756 is a high-severity code injection vulnerability in n/a, published on 9 Jun 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2013-1756 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- dragonfly (RubyGems): affected from 0.7; fixed in 0.8.6\n- dragonfly (RubyGems): affected from 0.7; fixed in 0.8.6\n- dragonfly (RubyGems): affected from 0.9; fixed in 0.9.13\n- dragonfly (RubyGems): affected from 0.9; fixed in 0.9.13\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2013-1756/ (Markdown: https://insights.sbomify.com/CVE-2013-1756/index.md)","id":"CVE-2013-1756","markdown":"https://insights.sbomify.com/CVE-2013-1756/index.md","name":"CVE-2013-1756","record":{"aliases":["GHSA-p463-639r-q9g9"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby image processing gem","requires_auth":"none","summary":"Remote attackers can execute arbitrary code via crafted requests in the Dragonfly Ruby gem, requiring an upgrade to secure applications.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"dragonfly_gem","vendor":"mark_evans"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"AV:N/AC:L/Au:N/C:P/I:P/A:P","version":"2.0"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"The Dragonfly gem 0.7 before 0.8.6 and 0.9.x before 0.9.13 for Ruby, when used with Ruby on Rails, allows remote attackers to execute arbitrary code via a crafted request.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Dragonfly Code Injection vulnerability","id":"CVE-2013-1756","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"code_injection","year":"2013"},"n_packages":4,"n_references":5,"next":{"headline":"Cross-site scripting in n/a","id":"CVE-2013-1758"},"packages":[{"ecosystem":"RubyGems","fixed":["0.8.6"],"introduced":["0.7"],"last_affected":[],"package":"dragonfly","purl":null,"source":"GHSA-p463-639r-q9g9"},{"ecosystem":"RubyGems","fixed":["0.8.6"],"introduced":["0.7"],"last_affected":[],"package":"dragonfly","purl":"pkg:gem/dragonfly","source":"GHSA-p463-639r-q9g9"},{"ecosystem":"RubyGems","fixed":["0.9.13"],"introduced":["0.9"],"last_affected":[],"package":"dragonfly","purl":null,"source":"GHSA-p463-639r-q9g9"},{"ecosystem":"RubyGems","fixed":["0.9.13"],"introduced":["0.9"],"last_affected":[],"package":"dragonfly","purl":"pkg:gem/dragonfly","source":"GHSA-p463-639r-q9g9"}],"prev":{"headline":"Denial of service in n/a","id":"CVE-2013-1753"},"products":["n/a"],"published":"2014-06-09","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can execute arbitrary code via crafted requests in the Dragonfly Ruby gem, requiring an upgrade to secure applications.","url":"https://insights.sbomify.com/CVE-2013-1756/"}