# CVE-2013-1756: Dragonfly Code Injection vulnerability

> Remote attackers can execute arbitrary code via crafted requests in the Dragonfly Ruby gem, requiring an upgrade to secure applications.

- **Severity:** High 7.5 (`AV:N/AC:L/Au:N/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Jun 2014
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-p463-639r-q9g9

## What is CVE-2013-1756?

CVE-2013-1756 is a high-severity code injection vulnerability in n/a, published on 9 Jun 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The Dragonfly gem 0.7 before 0.8.6 and 0.9.x before 0.9.13 for Ruby, when used with Ruby on Rails, allows remote attackers to execute arbitrary code via a crafted request.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2013-1756?

4 open source packages ship an affected version, including dragonfly. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `dragonfly` | RubyGems | From 0.7 | 0.8.6 |
| `dragonfly` | RubyGems | From 0.7 | 0.8.6 |
| `dragonfly` | RubyGems | From 0.9 | 0.9.13 |
| `dragonfly` | RubyGems | From 0.9 | 0.9.13 |

Products: Mark Evans Dragonfly Gem.

## How do I fix CVE-2013-1756?

Upgrade dragonfly to a fixed version for your release line: 0.8.6 or 0.9.13.

## Is CVE-2013-1756 being exploited?

There is no known exploitation of CVE-2013-1756 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2013-1756 and fix it if it is affected.

What it is: CVE-2013-1756 is a high-severity code injection vulnerability in n/a, published on 9 Jun 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2013-1756 in the wild and no public exploit code.

Affected packages and fixed versions:
- dragonfly (RubyGems): affected from 0.7; fixed in 0.8.6
- dragonfly (RubyGems): affected from 0.7; fixed in 0.8.6
- dragonfly (RubyGems): affected from 0.9; fixed in 0.9.13
- dragonfly (RubyGems): affected from 0.9; fixed in 0.9.13

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2013-1756/ (Markdown: https://insights.sbomify.com/CVE-2013-1756/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2013-1756
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2013-1756
- OSV: https://osv.dev/vulnerability/CVE-2013-1756

---
From sbomify Insights: https://insights.sbomify.com/CVE-2013-1756/
Summaries are generated and may contain mistakes; the official description above is the record.
