# CVE-2013-1768: Deserialization of Untrusted Data in Apache OpenJPA

> Remote attackers can execute arbitrary code by sending crafted serialized objects to applications using Apache OpenJPA with logging enabled.

- **Severity:** High 7.5 (`AV:N/AC:L/Au:N/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Jul 2013
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2013-1768, GHSA-j65f-mvgw-prp2, MGASA-2013-0292

## What is CVE-2013-1768?

CVE-2013-1768 is a high-severity unsafe deserialization vulnerability in n/a, published on 11 Jul 2013. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The BrokerFactory functionality in Apache OpenJPA 1.x before 1.2.3 and 2.x before 2.2.2 creates local executable JSP files containing logging trace data produced during deserialization of certain crafted OpenJPA objects, which makes it easier for remote attackers to execute arbitrary code by creating a serialized object and leveraging improperly secured server programs.

Weakness: CWE-264

## Which versions are affected by CVE-2013-1768?

4 open source packages ship an affected version, including org.apache.openjpa:openjpa. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.openjpa:openjpa` | Maven | From 1.0.0 | 1.2.3 |
| `org.apache.openjpa:openjpa` | Maven | From 1.0.0 | 1.2.3 |
| `org.apache.openjpa:openjpa` | Maven | From 2.0.0 | 2.2.2 |
| `org.apache.openjpa:openjpa` | Maven | From 2.0.0 | 2.2.2 |

Products: Apache Openjpa.

## How do I fix CVE-2013-1768?

Upgrade org.apache.openjpa:openjpa to a fixed version for your release line: 1.2.3 or 2.2.2.

## Is CVE-2013-1768 being exploited?

There is no known exploitation of CVE-2013-1768 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2013-1768 and fix it if it is affected.

What it is: CVE-2013-1768 is a high-severity unsafe deserialization vulnerability in n/a, published on 11 Jul 2013. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2013-1768 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.openjpa:openjpa (Maven): affected from 1.0.0; fixed in 1.2.3
- org.apache.openjpa:openjpa (Maven): affected from 1.0.0; fixed in 1.2.3
- org.apache.openjpa:openjpa (Maven): affected from 2.0.0; fixed in 2.2.2
- org.apache.openjpa:openjpa (Maven): affected from 2.0.0; fixed in 2.2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2013-1768/ (Markdown: https://insights.sbomify.com/CVE-2013-1768/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2013-1768
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2013-1768
- OSV: https://osv.dev/vulnerability/CVE-2013-1768

---
From sbomify Insights: https://insights.sbomify.com/CVE-2013-1768/
Summaries are generated and may contain mistakes; the official description above is the record.
