{"answers":{"affected":"2 open source packages ship an affected version, including extlib. It affects 1 product.","exploited":"There is no known exploitation of CVE-2013-1802 in the wild and no public exploit code.","fix":"Upgrade extlib to 0.9.16 or later.","what":"CVE-2013-1802 is a high-severity unsafe deserialization vulnerability in n/a, published on 9 Apr 2013. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2013-1802 and fix it if it is affected.\n\nWhat it is: CVE-2013-1802 is a high-severity unsafe deserialization vulnerability in n/a, published on 9 Apr 2013. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2013-1802 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- extlib (RubyGems): affected all versions; fixed in 0.9.16\n- extlib (RubyGems): affected all versions; fixed in 0.9.16\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2013-1802/ (Markdown: https://insights.sbomify.com/CVE-2013-1802/index.md)","id":"CVE-2013-1802","markdown":"https://insights.sbomify.com/CVE-2013-1802/index.md","name":"CVE-2013-1802","record":{"aliases":["DEBIAN-CVE-2013-1802","DLA-172-1","GHSA-9h36-4jf2-hx53"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby extlib gem","requires_auth":"none","summary":"Remote attackers can execute arbitrary code or cause denial of service via unsafe YAML or Symbol type conversion in the Ruby extlib gem.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"extlib","vendor":"dan_kubb"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"AV:N/AC:L/Au:N/C:P/I:P/A:P","version":"2.0"},"cwes":[{"id":"CWE-264","name":null}],"description":"The extlib gem 0.9.15 and earlier for Ruby does not properly restrict casts of string values, which might allow remote attackers to conduct object-injection attacks and execute arbitrary code, or cause a denial of service (memory and CPU consumption) by leveraging Action Pack support for (1) YAML type conversion or (2) Symbol type conversion, a similar vulnerability to CVE-2013-0156.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"extlib does not properly restrict casts of string values","id":"CVE-2013-1802","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"deserialization","year":"2013"},"n_packages":2,"n_references":4,"next":{"headline":"SQL injection in n/a","id":"CVE-2013-1803"},"packages":[{"ecosystem":"RubyGems","fixed":["0.9.16"],"introduced":["0"],"last_affected":[],"package":"extlib","purl":null,"source":"GHSA-9h36-4jf2-hx53"},{"ecosystem":"RubyGems","fixed":["0.9.16"],"introduced":["0"],"last_affected":[],"package":"extlib","purl":"pkg:gem/extlib","source":"GHSA-9h36-4jf2-hx53"}],"prev":{"headline":"HTTParty does not restrict casts of string values","id":"CVE-2013-1801"},"products":["n/a"],"published":"2013-04-09","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can execute arbitrary code or cause denial of service via unsafe YAML or Symbol type conversion in the Ruby extlib gem.","url":"https://insights.sbomify.com/CVE-2013-1802/"}