# CVE-2013-1802: extlib does not properly restrict casts of string values

> Remote attackers can execute arbitrary code or cause denial of service via unsafe YAML or Symbol type conversion in the Ruby extlib gem.

- **Severity:** High 7.5 (`AV:N/AC:L/Au:N/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Apr 2013
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2013-1802, DLA-172-1, GHSA-9h36-4jf2-hx53

## What is CVE-2013-1802?

CVE-2013-1802 is a high-severity unsafe deserialization vulnerability in n/a, published on 9 Apr 2013. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The extlib gem 0.9.15 and earlier for Ruby does not properly restrict casts of string values, which might allow remote attackers to conduct object-injection attacks and execute arbitrary code, or cause a denial of service (memory and CPU consumption) by leveraging Action Pack support for (1) YAML type conversion or (2) Symbol type conversion, a similar vulnerability to CVE-2013-0156.

Weakness: CWE-264

## Which versions are affected by CVE-2013-1802?

2 open source packages ship an affected version, including extlib. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `extlib` | RubyGems | All versions | 0.9.16 |
| `extlib` | RubyGems | All versions | 0.9.16 |

Products: Dan Kubb Extlib.

## How do I fix CVE-2013-1802?

Upgrade extlib to 0.9.16 or later.

## Is CVE-2013-1802 being exploited?

There is no known exploitation of CVE-2013-1802 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2013-1802 and fix it if it is affected.

What it is: CVE-2013-1802 is a high-severity unsafe deserialization vulnerability in n/a, published on 9 Apr 2013. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2013-1802 in the wild and no public exploit code.

Affected packages and fixed versions:
- extlib (RubyGems): affected all versions; fixed in 0.9.16
- extlib (RubyGems): affected all versions; fixed in 0.9.16

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2013-1802/ (Markdown: https://insights.sbomify.com/CVE-2013-1802/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2013-1802
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2013-1802
- OSV: https://osv.dev/vulnerability/CVE-2013-1802

---
From sbomify Insights: https://insights.sbomify.com/CVE-2013-1802/
Summaries are generated and may contain mistakes; the official description above is the record.
