{"answers":{"affected":"2 open source packages ship an affected version, including ruby-openid. It affects 2 products.","exploited":"There is no known exploitation of CVE-2013-1812 in the wild and no public exploit code.","fix":"Upgrade ruby-openid to 2.2.2 or later.","what":"CVE-2013-1812 is a medium-severity denial of service vulnerability in Fedoraproject Fedora, published on 12 Dec 2013. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2013-1812 and fix it if it is affected.\n\nWhat it is: CVE-2013-1812 is a medium-severity denial of service vulnerability in Fedoraproject Fedora, published on 12 Dec 2013. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2013-1812 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ruby-openid (RubyGems): affected all versions; fixed in 2.2.2\n- ruby-openid (RubyGems): affected all versions; fixed in 2.2.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2013-1812/ (Markdown: https://insights.sbomify.com/CVE-2013-1812/index.md)","id":"CVE-2013-1812","markdown":"https://insights.sbomify.com/CVE-2013-1812/index.md","name":"CVE-2013-1812","record":{"aliases":["DEBIAN-CVE-2013-1812","GHSA-6c8p-qphv-668v"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby OpenID library","requires_auth":"none","summary":"Remote attackers can cause denial of service via CPU exhaustion using large XRDS documents or XML Entity Expansion attacks in the ruby-openid gem.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"fedora","vendor":"fedoraproject"},{"product":"ruby-openid","vendor":"janrain"}],"cvss":{"score":4.3,"severity":"medium","source":"nvd","vector":"AV:N/AC:M/Au:N/C:N/I:N/A:P","version":"2.0"},"cwes":[{"id":"CWE-399","name":null}],"description":"The ruby-openid gem before 2.2.2 for Ruby allows remote OpenID providers to cause a denial of service (CPU consumption) via (1) a large XRDS document or (2) an XML Entity Expansion (XEE) attack.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Denial of service in ruby-openid","id":"CVE-2013-1812","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":"fedoraproject:fedora","products":["fedoraproject:fedora"],"type":"denial_of_service","year":"2013"},"n_packages":2,"n_references":7,"next":{"headline":"Misconfiguration in n/a","id":"CVE-2013-1813"},"packages":[{"ecosystem":"RubyGems","fixed":["2.2.2"],"introduced":["0"],"last_affected":[],"package":"ruby-openid","purl":null,"source":"GHSA-6c8p-qphv-668v"},{"ecosystem":"RubyGems","fixed":["2.2.2"],"introduced":["0"],"last_affected":[],"package":"ruby-openid","purl":"pkg:gem/ruby-openid","source":"GHSA-6c8p-qphv-668v"}],"prev":{"headline":"Missing authorization in mantis","id":"CVE-2013-1811"},"products":["n/a"],"published":"2013-12-12","related":[{"cvss_score":9.8,"headline":"PHP-CGI OS Command Injection","id":"CVE-2024-4577","kev_date_added":"2024-06-12","published":"2024-06-09"},{"cvss_score":9.8,"headline":"Grafana Authentication Bypass","id":"CVE-2021-39226","kev_date_added":"2022-08-25","published":"2021-10-05"},{"cvss_score":9.8,"headline":"VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow","id":"CVE-2019-5544","kev_date_added":"2021-11-03","published":"2019-12-06"},{"cvss_score":9.6,"headline":"Google Chromium V8 Type Confusion","id":"CVE-2024-4947","kev_date_added":"2024-05-20","published":"2024-05-15"},{"cvss_score":9.6,"headline":"Google Chromium Visuals Use-After-Free","id":"CVE-2024-4671","kev_date_added":"2024-05-13","published":"2024-05-09"},{"cvss_score":9.6,"headline":"Google Chromium Mojo Insufficient Data Validation","id":"CVE-2022-3075","kev_date_added":"2022-09-08","published":"2022-09-26"},{"cvss_score":9.6,"headline":"Google Chromium Indexed DB API Use-After-Free","id":"CVE-2021-30633","kev_date_added":"2021-11-03","published":"2021-10-08"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can cause denial of service via CPU exhaustion using large XRDS documents or XML Entity Expansion attacks in the ruby-openid gem.","url":"https://insights.sbomify.com/CVE-2013-1812/"}