# CVE-2013-1814: Apache Rave information disclosure vulnerability

> Authenticated users can retrieve sensitive information, including password hashes, for all user accounts via the User RPC API.

- **Severity:** Medium 4.0 (`AV:N/AC:L/Au:S/C:P/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Mar 2013
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-428j-q447-47rw

## What is CVE-2013-1814?

CVE-2013-1814 is a medium-severity vulnerability in n/a, published on 14 Mar 2013. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The users/get program in the User RPC API in Apache Rave 0.11 through 0.20 allows remote authenticated users to obtain sensitive information about all user accounts via the offset parameter, as demonstrated by discovering password hashes in the password field of a response.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2013-1814?

6 open source packages ship an affected version, including org.apache.rave:rave-core, org.apache.rave:rave-portal-resources and org.apache.rave:rave-web. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.rave:rave-core` | Maven | From 0.11 | 0.20.1 |
| `org.apache.rave:rave-core` | Maven | From 0.11 | 0.20.1 |
| `org.apache.rave:rave-portal-resources` | Maven | From 0.11 | 0.20.1 |
| `org.apache.rave:rave-portal-resources` | Maven | From 0.11 | 0.20.1 |
| `org.apache.rave:rave-web` | Maven | From 0.11 | 0.20.1 |
| `org.apache.rave:rave-web` | Maven | From 0.11 | 0.20.1 |

Products: Apache Rave.

## How do I fix CVE-2013-1814?

Upgrade org.apache.rave:rave-core to 0.20.1 or later.

## Is CVE-2013-1814 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2013-1814 exists.

Public exploit code:

- Apache Rave 0.11 < 0.20 - User Information Disclosure (exploitdb)
- EXPOSURE demo target: Tomcat (CVE-2016-0714) + Apache Rave (CVE-2013-1814) + Java filter-padding deps (github_poc): https://github.com/dannyEndorTest/java-vulnerable
- Apache Rave User Information Disclosure (metasploit)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2013-1814 and fix it if it is affected.

What it is: CVE-2013-1814 is a medium-severity vulnerability in n/a, published on 14 Mar 2013. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2013-1814 exists.

Affected packages and fixed versions:
- org.apache.rave:rave-core (Maven): affected from 0.11; fixed in 0.20.1
- org.apache.rave:rave-core (Maven): affected from 0.11; fixed in 0.20.1
- org.apache.rave:rave-portal-resources (Maven): affected from 0.11; fixed in 0.20.1
- org.apache.rave:rave-portal-resources (Maven): affected from 0.11; fixed in 0.20.1
- org.apache.rave:rave-web (Maven): affected from 0.11; fixed in 0.20.1
- org.apache.rave:rave-web (Maven): affected from 0.11; fixed in 0.20.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2013-1814/ (Markdown: https://insights.sbomify.com/CVE-2013-1814/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2013-1814
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2013-1814
- OSV: https://osv.dev/vulnerability/CVE-2013-1814

---
From sbomify Insights: https://insights.sbomify.com/CVE-2013-1814/
Summaries are generated and may contain mistakes; the official description above is the record.
