{"answers":{"affected":"2 open source packages ship an affected version, including org.jruby:jruby. It affects 1 product.","exploited":"There is no known exploitation of CVE-2013-1821 in the wild and no public exploit code.","fix":"Upgrade org.jruby:jruby to 1.7.3 or later.","what":"CVE-2013-1821 is a medium-severity denial of service vulnerability in Ruby-Lang Ruby, published on 9 Apr 2013. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2013-1821 and fix it if it is affected.\n\nWhat it is: CVE-2013-1821 is a medium-severity denial of service vulnerability in Ruby-Lang Ruby, published on 9 Apr 2013. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2013-1821 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jruby:jruby (Maven): affected all versions; fixed in 1.7.3\n- org.jruby:jruby (Maven): affected all versions; fixed in 1.7.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2013-1821/ (Markdown: https://insights.sbomify.com/CVE-2013-1821/index.md)","id":"CVE-2013-1821","markdown":"https://insights.sbomify.com/CVE-2013-1821/index.md","name":"CVE-2013-1821","record":{"aliases":["GHSA-hgg7-cghq-xhf4","RHSA-2013:0611"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby XML parser","requires_auth":"none","summary":"Remote attackers can cause denial of service via memory exhaustion in the Ruby REXML parser using crafted XML entity expansion.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"ruby","vendor":"ruby-lang"}],"cvss":{"score":5,"severity":"medium","source":"nvd","vector":"AV:N/AC:L/Au:N/C:N/I:N/A:P","version":"2.0"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"lib/rexml/text.rb in the REXML parser in Ruby before 1.9.3-p392 allows remote attackers to cause a denial of service (memory consumption and crash) via crafted text nodes in an XML document, aka an XML Entity Expansion (XEE) attack.","ecosystems":["Maven","Red Hat:enterprise_linux:5::server"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Ruby vulnerable to denial of service","id":"CVE-2013-1821","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":"ruby-lang:ruby","products":["ruby-lang:ruby"],"type":"denial_of_service","year":"2013"},"n_packages":12,"n_references":23,"next":{"headline":"Cross-site scripting in n/a","id":"CVE-2013-1822"},"packages":[{"ecosystem":"Maven","fixed":["1.7.3"],"introduced":["0"],"last_affected":[],"package":"org.jruby:jruby","purl":null,"source":"GHSA-hgg7-cghq-xhf4"},{"ecosystem":"Maven","fixed":["1.7.3"],"introduced":["0"],"last_affected":[],"package":"org.jruby:jruby","purl":"pkg:maven/org.jruby/jruby","source":"GHSA-hgg7-cghq-xhf4"},{"ecosystem":"Red Hat:enterprise_linux:5::server","fixed":["0:1.8.5-29.el5_9"],"introduced":["0"],"last_affected":[],"package":"ruby","purl":"pkg:rpm/redhat/ruby","source":"RHSA-2013:0611"},{"ecosystem":"Red Hat:enterprise_linux:5::server","fixed":["0:1.8.5-29.el5_9"],"introduced":["0"],"last_affected":[],"package":"ruby-debuginfo","purl":"pkg:rpm/redhat/ruby-debuginfo","source":"RHSA-2013:0611"},{"ecosystem":"Red Hat:enterprise_linux:5::server","fixed":["0:1.8.5-29.el5_9"],"introduced":["0"],"last_affected":[],"package":"ruby-devel","purl":"pkg:rpm/redhat/ruby-devel","source":"RHSA-2013:0611"},{"ecosystem":"Red Hat:enterprise_linux:5::server","fixed":["0:1.8.5-29.el5_9"],"introduced":["0"],"last_affected":[],"package":"ruby-docs","purl":"pkg:rpm/redhat/ruby-docs","source":"RHSA-2013:0611"},{"ecosystem":"Red Hat:enterprise_linux:5::server","fixed":["0:1.8.5-29.el5_9"],"introduced":["0"],"last_affected":[],"package":"ruby-irb","purl":"pkg:rpm/redhat/ruby-irb","source":"RHSA-2013:0611"},{"ecosystem":"Red Hat:enterprise_linux:5::server","fixed":["0:1.8.5-29.el5_9"],"introduced":["0"],"last_affected":[],"package":"ruby-libs","purl":"pkg:rpm/redhat/ruby-libs","source":"RHSA-2013:0611"},{"ecosystem":"Red Hat:enterprise_linux:5::server","fixed":["0:1.8.5-29.el5_9"],"introduced":["0"],"last_affected":[],"package":"ruby-mode","purl":"pkg:rpm/redhat/ruby-mode","source":"RHSA-2013:0611"},{"ecosystem":"Red Hat:enterprise_linux:5::server","fixed":["0:1.8.5-29.el5_9"],"introduced":["0"],"last_affected":[],"package":"ruby-rdoc","purl":"pkg:rpm/redhat/ruby-rdoc","source":"RHSA-2013:0611"},{"ecosystem":"Red Hat:enterprise_linux:5::server","fixed":["0:1.8.5-29.el5_9"],"introduced":["0"],"last_affected":[],"package":"ruby-ri","purl":"pkg:rpm/redhat/ruby-ri","source":"RHSA-2013:0611"},{"ecosystem":"Red Hat:enterprise_linux:5::server","fixed":["0:1.8.5-29.el5_9"],"introduced":["0"],"last_affected":[],"package":"ruby-tcltk","purl":"pkg:rpm/redhat/ruby-tcltk","source":"RHSA-2013:0611"}],"prev":{"headline":"Privilege escalation in tuned","id":"CVE-2013-1820"},"products":["n/a"],"published":"2013-04-09","related":[{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2009-4124","kev_date_added":null,"published":"2009-12-11"},{"cvss_score":9.8,"headline":"Use after free in n/a","id":"CVE-2022-28738","kev_date_added":null,"published":"2022-05-09"},{"cvss_score":9.8,"headline":"Weak cryptography in OpenSSL extension of Ruby (Git trunk)","id":"CVE-2011-4121","kev_date_added":null,"published":"2019-11-26"},{"cvss_score":9.8,"headline":"Command injection in n/a","id":"CVE-2017-17790","kev_date_added":null,"published":"2017-12-20"},{"cvss_score":9.8,"headline":"Memory corruption in n/a","id":"CVE-2017-11465","kev_date_added":null,"published":"2017-07-19"},{"cvss_score":9.8,"headline":"Memory corruption in Ruby","id":"CVE-2016-2336","kev_date_added":null,"published":"2017-01-06"},{"cvss_score":9.8,"headline":"Code injection in Ruby","id":"CVE-2016-2337","kev_date_added":null,"published":"2017-01-06"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Red Hat","prefix":"RHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can cause denial of service via memory exhaustion in the Ruby REXML parser using crafted XML entity expansion.","url":"https://insights.sbomify.com/CVE-2013-1821/"}