# CVE-2013-1821: Ruby vulnerable to denial of service

> Remote attackers can cause denial of service via memory exhaustion in the Ruby REXML parser using crafted XML entity expansion.

- **Severity:** Medium 5.0 (`AV:N/AC:L/Au:N/C:N/I:N/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Apr 2013
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-hgg7-cghq-xhf4, RHSA-2013:0611

## What is CVE-2013-1821?

CVE-2013-1821 is a medium-severity denial of service vulnerability in Ruby-Lang Ruby, published on 9 Apr 2013. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

lib/rexml/text.rb in the REXML parser in Ruby before 1.9.3-p392 allows remote attackers to cause a denial of service (memory consumption and crash) via crafted text nodes in an XML document, aka an XML Entity Expansion (XEE) attack.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2013-1821?

2 open source packages ship an affected version, including org.jruby:jruby. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jruby:jruby` | Maven | All versions | 1.7.3 |
| `org.jruby:jruby` | Maven | All versions | 1.7.3 |
| `ruby` | Red Hat:enterprise_linux:5::server | All versions | 0:1.8.5-29.el5_9 |
| `ruby-debuginfo` | Red Hat:enterprise_linux:5::server | All versions | 0:1.8.5-29.el5_9 |
| `ruby-devel` | Red Hat:enterprise_linux:5::server | All versions | 0:1.8.5-29.el5_9 |
| `ruby-docs` | Red Hat:enterprise_linux:5::server | All versions | 0:1.8.5-29.el5_9 |
| `ruby-irb` | Red Hat:enterprise_linux:5::server | All versions | 0:1.8.5-29.el5_9 |
| `ruby-libs` | Red Hat:enterprise_linux:5::server | All versions | 0:1.8.5-29.el5_9 |
| `ruby-mode` | Red Hat:enterprise_linux:5::server | All versions | 0:1.8.5-29.el5_9 |
| `ruby-rdoc` | Red Hat:enterprise_linux:5::server | All versions | 0:1.8.5-29.el5_9 |
| `ruby-ri` | Red Hat:enterprise_linux:5::server | All versions | 0:1.8.5-29.el5_9 |
| `ruby-tcltk` | Red Hat:enterprise_linux:5::server | All versions | 0:1.8.5-29.el5_9 |

Products: Ruby-Lang Ruby.

## How do I fix CVE-2013-1821?

Upgrade org.jruby:jruby to 1.7.3 or later.

## Is CVE-2013-1821 being exploited?

There is no known exploitation of CVE-2013-1821 in the wild and no public exploit code.

## Other vulnerabilities in Ruby-Lang Ruby

- [CVE-2009-4124](https://insights.sbomify.com/CVE-2009-4124/): Memory corruption in n/a (critical 10.0)
- [CVE-2022-28738](https://insights.sbomify.com/CVE-2022-28738/): Use after free in n/a (critical 9.8)
- [CVE-2011-4121](https://insights.sbomify.com/CVE-2011-4121/): Weak cryptography in OpenSSL extension of Ruby (Git trunk) (critical 9.8)
- [CVE-2017-17790](https://insights.sbomify.com/CVE-2017-17790/): Command injection in n/a (critical 9.8)
- [CVE-2017-11465](https://insights.sbomify.com/CVE-2017-11465/): Memory corruption in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2013-1821 and fix it if it is affected.

What it is: CVE-2013-1821 is a medium-severity denial of service vulnerability in Ruby-Lang Ruby, published on 9 Apr 2013. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2013-1821 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jruby:jruby (Maven): affected all versions; fixed in 1.7.3
- org.jruby:jruby (Maven): affected all versions; fixed in 1.7.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2013-1821/ (Markdown: https://insights.sbomify.com/CVE-2013-1821/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2013-1821
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2013-1821
- OSV: https://osv.dev/vulnerability/CVE-2013-1821

---
From sbomify Insights: https://insights.sbomify.com/CVE-2013-1821/
Summaries are generated and may contain mistakes; the official description above is the record.
