{"answers":{"affected":"8 open source packages ship an affected version, including moodle/moodle. It affects 2 products.","exploited":"There is no known exploitation of CVE-2013-1830 in the wild and no public exploit code.","fix":"Upgrade moodle/moodle to a fixed version for your release line: 2.2.8, 2.3.5 or 2.4.2.","what":"CVE-2013-1830 is a medium-severity missing authorization vulnerability in Fedoraproject Fedora, published on 25 Mar 2013. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2013-1830 and fix it if it is affected.\n\nWhat it is: CVE-2013-1830 is a medium-severity missing authorization vulnerability in Fedoraproject Fedora, published on 25 Mar 2013. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2013-1830 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- moodle/moodle (Packagist): affected all versions up to 2.1.10; no fix listed\n- moodle/moodle (Packagist): affected all versions up to 2.1.10; no fix listed\n- moodle/moodle (Packagist): affected from 2.2.0; fixed in 2.2.8\n- moodle/moodle (Packagist): affected from 2.2.0; fixed in 2.2.8\n- moodle/moodle (Packagist): affected from 2.3.0; fixed in 2.3.5\n- moodle/moodle (Packagist): affected from 2.3.0; fixed in 2.3.5\n- moodle/moodle (Packagist): affected from 2.4.0; fixed in 2.4.2\n- moodle/moodle (Packagist): affected from 2.4.0; fixed in 2.4.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2013-1830/ (Markdown: https://insights.sbomify.com/CVE-2013-1830/index.md)","id":"CVE-2013-1830","markdown":"https://insights.sbomify.com/CVE-2013-1830/index.md","name":"CVE-2013-1830","record":{"aliases":["GHSA-8r7x-qq55-74v2","UBUNTU-CVE-2013-1830"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":true,"product_category":"Moodle LMS","requires_auth":"low_privilege","summary":"Remote attackers with guest access can view sensitive course profiles in Moodle if the forceloginforprofiles setting is not enforced.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"fedora","vendor":"fedoraproject"},{"product":"moodle","vendor":"moodle"}],"cvss":{"score":5,"severity":"medium","source":"nvd","vector":"AV:N/AC:L/Au:N/C:P/I:N/A:N","version":"2.0"},"cwes":[{"id":"CWE-264","name":null}],"description":"user/view.php in Moodle through 2.1.10, 2.2.x before 2.2.8, 2.3.x before 2.3.5, and 2.4.x before 2.4.2 does not enforce the forceloginforprofiles setting, which allows remote attackers to obtain sensitive course-profile information by leveraging the guest role, as demonstrated by a Google search.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Moodle does not enforce the forceloginforprofiles setting","id":"CVE-2013-1830","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"fedoraproject:fedora","products":["fedoraproject:fedora","moodle:moodle"],"type":"missing_authorization","year":"2013"},"n_packages":8,"n_references":5,"next":{"headline":"Moodle reveals absolute path in exception message","id":"CVE-2013-1831"},"packages":[{"ecosystem":"Packagist","fixed":[],"introduced":["0"],"last_affected":["2.1.10"],"package":"moodle/moodle","purl":null,"source":"GHSA-8r7x-qq55-74v2"},{"ecosystem":"Packagist","fixed":[],"introduced":["0"],"last_affected":["2.1.10"],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-8r7x-qq55-74v2"},{"ecosystem":"Packagist","fixed":["2.2.8"],"introduced":["2.2.0"],"last_affected":[],"package":"moodle/moodle","purl":null,"source":"GHSA-8r7x-qq55-74v2"},{"ecosystem":"Packagist","fixed":["2.2.8"],"introduced":["2.2.0"],"last_affected":[],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-8r7x-qq55-74v2"},{"ecosystem":"Packagist","fixed":["2.3.5"],"introduced":["2.3.0"],"last_affected":[],"package":"moodle/moodle","purl":null,"source":"GHSA-8r7x-qq55-74v2"},{"ecosystem":"Packagist","fixed":["2.3.5"],"introduced":["2.3.0"],"last_affected":[],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-8r7x-qq55-74v2"},{"ecosystem":"Packagist","fixed":["2.4.2"],"introduced":["2.4.0"],"last_affected":[],"package":"moodle/moodle","purl":null,"source":"GHSA-8r7x-qq55-74v2"},{"ecosystem":"Packagist","fixed":["2.4.2"],"introduced":["2.4.0"],"last_affected":[],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-8r7x-qq55-74v2"}],"prev":{"headline":"Missing authorization in n/a","id":"CVE-2013-1829"},"products":["n/a"],"published":"2013-03-25","related":[{"cvss_score":9.8,"headline":"PHP-CGI OS Command Injection","id":"CVE-2024-4577","kev_date_added":"2024-06-12","published":"2024-06-09"},{"cvss_score":9.8,"headline":"Grafana Authentication Bypass","id":"CVE-2021-39226","kev_date_added":"2022-08-25","published":"2021-10-05"},{"cvss_score":9.8,"headline":"VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow","id":"CVE-2019-5544","kev_date_added":"2021-11-03","published":"2019-12-06"},{"cvss_score":9.6,"headline":"Google Chromium V8 Type Confusion","id":"CVE-2024-4947","kev_date_added":"2024-05-20","published":"2024-05-15"},{"cvss_score":9.6,"headline":"Google Chromium Visuals Use-After-Free","id":"CVE-2024-4671","kev_date_added":"2024-05-13","published":"2024-05-09"},{"cvss_score":9.6,"headline":"Google Chromium Mojo Insufficient Data Validation","id":"CVE-2022-3075","kev_date_added":"2022-09-08","published":"2022-09-26"},{"cvss_score":9.6,"headline":"Google Chromium Indexed DB API Use-After-Free","id":"CVE-2021-30633","kev_date_added":"2021-11-03","published":"2021-10-08"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers with guest access can view sensitive course profiles in Moodle if the forceloginforprofiles setting is not enforced.","url":"https://insights.sbomify.com/CVE-2013-1830/"}