CVE-2013-1831 Moodle reveals absolute path in exception message

Medium 5.0 Published Updated

Remote attackers can obtain sensitive absolute path information via invalid requests in Moodle, potentially aiding further attacks.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2013-1831?

CVE-2013-1831 is a medium-severity vulnerability in Moodle Moodle, published on 25 Mar 2013. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

lib/setuplib.php in Moodle through 2.1.10, 2.2.x before 2.2.8, 2.3.x before 2.3.5, and 2.4.x before 2.4.2 allows remote attackers to obtain sensitive information via an invalid request, which reveals the absolute path in an exception message.

Weakness: CWE-200

Which versions are affected by CVE-2013-1831?

8 open source packages ship an affected version, including moodle/moodle. It affects 1 product.

PackageAffectedFixed in
moodle/moodle PackagistAll versions to 2.1.10None
moodle/moodle PackagistAll versions to 2.1.10None
moodle/moodle PackagistFrom 2.2.02.2.8
moodle/moodle PackagistFrom 2.2.02.2.8
moodle/moodle PackagistFrom 2.3.02.3.5
moodle/moodle PackagistFrom 2.3.02.3.5
2 more packages
moodle/moodle PackagistFrom 2.4.02.4.2
moodle/moodle PackagistFrom 2.4.02.4.2

Products include Moodle Moodle.

How do I fix CVE-2013-1831?

Upgrade moodle/moodle to a fixed version for your release line: 2.2.8, 2.3.5 or 2.4.2.

Is CVE-2013-1831 being exploited?

There is no known exploitation of CVE-2013-1831 in the wild and no public exploit code.

All Moodle Moodle vulnerabilities

Sources

Also known as GHSA-xr24-jp5c-6c4v, UBUNTU-CVE-2013-1831.

Is CVE-2013-1831 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free