{"answers":{"affected":"8 open source packages ship an affected version, including moodle/moodle. It affects 1 product.","exploited":"There is no known exploitation of CVE-2013-1832 in the wild and no public exploit code.","fix":"Upgrade moodle/moodle to a fixed version for your release line: 2.2.8, 2.3.5 or 2.4.2.","what":"CVE-2013-1832 is a medium-severity vulnerability in Moodle Moodle, published on 25 Mar 2013. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2013-1832 and fix it if it is affected.\n\nWhat it is: CVE-2013-1832 is a medium-severity vulnerability in Moodle Moodle, published on 25 Mar 2013. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2013-1832 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- moodle/moodle (Packagist): affected from 2.0.0 up to 2.1.10; no fix listed\n- moodle/moodle (Packagist): affected from 2.0.0 up to 2.1.10; no fix listed\n- moodle/moodle (Packagist): affected from 2.2.0; fixed in 2.2.8\n- moodle/moodle (Packagist): affected from 2.2.0; fixed in 2.2.8\n- moodle/moodle (Packagist): affected from 2.3.0; fixed in 2.3.5\n- moodle/moodle (Packagist): affected from 2.3.0; fixed in 2.3.5\n- moodle/moodle (Packagist): affected from 2.4.0; fixed in 2.4.2\n- moodle/moodle (Packagist): affected from 2.4.0; fixed in 2.4.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2013-1832/ (Markdown: https://insights.sbomify.com/CVE-2013-1832/index.md)","id":"CVE-2013-1832","markdown":"https://insights.sbomify.com/CVE-2013-1832/index.md","name":"CVE-2013-1832","record":{"aliases":["GHSA-pgp5-rcwp-qvfg","UBUNTU-CVE-2013-1832"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":true,"product_category":"Moodle LMS","requires_auth":"high_privilege","summary":"Authenticated administrators can view WebDAV passwords in the configuration form, exposing sensitive credentials.","user_interaction":"required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"moodle","vendor":"moodle"}],"cvss":{"score":4,"severity":"medium","source":"nvd","vector":"AV:N/AC:L/Au:S/C:P/I:N/A:N","version":"2.0"},"cwes":[{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"repository/webdav/lib.php in Moodle 2.x through 2.1.10, 2.2.x before 2.2.8, 2.3.x before 2.3.5, and 2.4.x before 2.4.2 includes the WebDAV password in the configuration form, which allows remote authenticated administrators to obtain sensitive information by configuring an instance.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Moodle includes the WebDAV password in the configuration form","id":"CVE-2013-1832","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"moodle:moodle","products":["moodle:moodle"],"type":"information_disclosure","year":"2013"},"n_packages":8,"n_references":5,"next":{"headline":"Moodle Multiple cross-site scripting (XSS) vulnerabilities in the File Picker module","id":"CVE-2013-1833"},"packages":[{"ecosystem":"Packagist","fixed":[],"introduced":["2.0.0"],"last_affected":["2.1.10"],"package":"moodle/moodle","purl":null,"source":"GHSA-pgp5-rcwp-qvfg"},{"ecosystem":"Packagist","fixed":[],"introduced":["2.0.0"],"last_affected":["2.1.10"],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-pgp5-rcwp-qvfg"},{"ecosystem":"Packagist","fixed":["2.2.8"],"introduced":["2.2.0"],"last_affected":[],"package":"moodle/moodle","purl":null,"source":"GHSA-pgp5-rcwp-qvfg"},{"ecosystem":"Packagist","fixed":["2.2.8"],"introduced":["2.2.0"],"last_affected":[],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-pgp5-rcwp-qvfg"},{"ecosystem":"Packagist","fixed":["2.3.5"],"introduced":["2.3.0"],"last_affected":[],"package":"moodle/moodle","purl":null,"source":"GHSA-pgp5-rcwp-qvfg"},{"ecosystem":"Packagist","fixed":["2.3.5"],"introduced":["2.3.0"],"last_affected":[],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-pgp5-rcwp-qvfg"},{"ecosystem":"Packagist","fixed":["2.4.2"],"introduced":["2.4.0"],"last_affected":[],"package":"moodle/moodle","purl":null,"source":"GHSA-pgp5-rcwp-qvfg"},{"ecosystem":"Packagist","fixed":["2.4.2"],"introduced":["2.4.0"],"last_affected":[],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-pgp5-rcwp-qvfg"}],"prev":{"headline":"Moodle reveals absolute path in exception message","id":"CVE-2013-1831"},"products":["n/a"],"published":"2013-03-25","related":[{"cvss_score":10,"headline":"File upload in n/a","id":"CVE-2006-4935","kev_date_added":null,"published":"2006-09-23"},{"cvss_score":10,"headline":"Moodle does not properly validate module instance id","id":"CVE-2006-4936","kev_date_added":null,"published":"2006-09-23"},{"cvss_score":10,"headline":"Unknown \"front page vulnerability with Moodle servers\" for Moodle before 1.3.2 has unknown impact and attack vectors.","id":"CVE-2004-2233","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Cross-site scripting in n/a","id":"CVE-2004-2235","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2004-2236","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Unknown vulnerability in Moodle before 1.3.4 has unknown impact and attack vectors, related to \"strings in Moodle texts.\"","id":"CVE-2004-2237","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Multiple unknown vulnerabilities in Moodle before 1.5.1 have unknown impact and attack vectors.","id":"CVE-2005-2247","kev_date_added":null,"published":"2005-07-12"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Authenticated administrators can view WebDAV passwords in the configuration form, exposing sensitive credentials.","url":"https://insights.sbomify.com/CVE-2013-1832/"}