CVE-2013-1833 Moodle Multiple cross-site scripting (XSS) vulnerabilities in the File Picker module
Authenticated users can inject arbitrary scripts via crafted filenames in the File Picker module, potentially leading to session hijacking or code execution.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2013-1833?
CVE-2013-1833 is a low-severity cross-site scripting vulnerability in Moodle Moodle, published on 25 Mar 2013. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
Multiple cross-site scripting (XSS) vulnerabilities in the File Picker module in Moodle 2.x through 2.1.10, 2.2.x before 2.2.8, 2.3.x before 2.3.5, and 2.4.x before 2.4.2 allow remote authenticated users to inject arbitrary web script or HTML via a crafted filename.
Weakness: CWE-79
Which versions are affected by CVE-2013-1833?
8 open source packages ship an affected version, including moodle/moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | From 2.0.0 to 2.1.10 | None |
moodle/moodle Packagist | From 2.0.0 to 2.1.10 | None |
moodle/moodle Packagist | From 2.2.0 | 2.2.8 |
moodle/moodle Packagist | From 2.2.0 | 2.2.8 |
moodle/moodle Packagist | From 2.3.0 | 2.3.5 |
moodle/moodle Packagist | From 2.3.0 | 2.3.5 |
2 more packages
moodle/moodle Packagist | From 2.4.0 | 2.4.2 |
moodle/moodle Packagist | From 2.4.0 | 2.4.2 |
Products include Moodle Moodle.
How do I fix CVE-2013-1833?
Upgrade moodle/moodle to a fixed version for your release line: 2.2.8, 2.3.5 or 2.4.2.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2013-1833 being exploited?
There is no known exploitation of CVE-2013-1833 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as GHSA-89f3-74m6-g27g, UBUNTU-CVE-2013-1833.