# CVE-2013-1833: Moodle Multiple cross-site scripting (XSS) vulnerabilities in the File Picker module

> Authenticated users can inject arbitrary scripts via crafted filenames in the File Picker module, potentially leading to session hijacking or code execution.

- **Severity:** Low 3.5 (`AV:N/AC:M/Au:S/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 25 Mar 2013
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-89f3-74m6-g27g, UBUNTU-CVE-2013-1833

## What is CVE-2013-1833?

CVE-2013-1833 is a low-severity cross-site scripting vulnerability in Moodle Moodle, published on 25 Mar 2013. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Multiple cross-site scripting (XSS) vulnerabilities in the File Picker module in Moodle 2.x through 2.1.10, 2.2.x before 2.2.8, 2.3.x before 2.3.5, and 2.4.x before 2.4.2 allow remote authenticated users to inject arbitrary web script or HTML via a crafted filename.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2013-1833?

8 open source packages ship an affected version, including moodle/moodle. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `moodle/moodle` | Packagist | From 2.0.0 to 2.1.10 | None |
| `moodle/moodle` | Packagist | From 2.0.0 to 2.1.10 | None |
| `moodle/moodle` | Packagist | From 2.2.0 | 2.2.8 |
| `moodle/moodle` | Packagist | From 2.2.0 | 2.2.8 |
| `moodle/moodle` | Packagist | From 2.3.0 | 2.3.5 |
| `moodle/moodle` | Packagist | From 2.3.0 | 2.3.5 |
| `moodle/moodle` | Packagist | From 2.4.0 | 2.4.2 |
| `moodle/moodle` | Packagist | From 2.4.0 | 2.4.2 |

Products: Moodle Moodle.

## How do I fix CVE-2013-1833?

Upgrade moodle/moodle to a fixed version for your release line: 2.2.8, 2.3.5 or 2.4.2.

## Is CVE-2013-1833 being exploited?

There is no known exploitation of CVE-2013-1833 in the wild and no public exploit code.

## Other vulnerabilities in Moodle Moodle

- [CVE-2006-4935](https://insights.sbomify.com/CVE-2006-4935/): File upload in n/a (critical 10.0)
- [CVE-2006-4936](https://insights.sbomify.com/CVE-2006-4936/): Moodle does not properly validate module instance id (critical 10.0)
- [CVE-2004-2233](https://insights.sbomify.com/CVE-2004-2233/): Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors. (critical 10.0)
- [CVE-2004-2235](https://insights.sbomify.com/CVE-2004-2235/): Cross-site scripting in n/a (critical 10.0)
- [CVE-2004-2236](https://insights.sbomify.com/CVE-2004-2236/): Other in n/a (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2013-1833 and fix it if it is affected.

What it is: CVE-2013-1833 is a low-severity cross-site scripting vulnerability in Moodle Moodle, published on 25 Mar 2013. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2013-1833 in the wild and no public exploit code.

Affected packages and fixed versions:
- moodle/moodle (Packagist): affected from 2.0.0 up to 2.1.10; no fix listed
- moodle/moodle (Packagist): affected from 2.0.0 up to 2.1.10; no fix listed
- moodle/moodle (Packagist): affected from 2.2.0; fixed in 2.2.8
- moodle/moodle (Packagist): affected from 2.2.0; fixed in 2.2.8
- moodle/moodle (Packagist): affected from 2.3.0; fixed in 2.3.5
- moodle/moodle (Packagist): affected from 2.3.0; fixed in 2.3.5
- moodle/moodle (Packagist): affected from 2.4.0; fixed in 2.4.2
- moodle/moodle (Packagist): affected from 2.4.0; fixed in 2.4.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2013-1833/ (Markdown: https://insights.sbomify.com/CVE-2013-1833/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2013-1833
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2013-1833
- OSV: https://osv.dev/vulnerability/CVE-2013-1833

---
From sbomify Insights: https://insights.sbomify.com/CVE-2013-1833/
Summaries are generated and may contain mistakes; the official description above is the record.
