CVE-2013-1835 Moodle's login_as feature leaks information from external repositories
Authenticated administrators can access sensitive information from arbitrary users' external repositories via the login_as feature.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2013-1835?
CVE-2013-1835 is a low-severity vulnerability in Moodle Moodle, published on 25 Mar 2013. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
Moodle 2.x through 2.1.10, 2.2.x before 2.2.8, 2.3.x before 2.3.5, and 2.4.x before 2.4.2 allows remote authenticated administrators to obtain sensitive information from the external repositories of arbitrary users by leveraging the login_as feature.
Weakness: CWE-200
Which versions are affected by CVE-2013-1835?
6 open source packages ship an affected version, including moodle/moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | From 2.0.0 | 2.2.8 |
moodle/moodle Packagist | From 2.0.0 | 2.2.8 |
moodle/moodle Packagist | From 2.3.0 | 2.3.5 |
moodle/moodle Packagist | From 2.3.0 | 2.3.5 |
moodle/moodle Packagist | From 2.4.0 | 2.4.2 |
moodle/moodle Packagist | From 2.4.0 | 2.4.2 |
Products include Moodle Moodle.
How do I fix CVE-2013-1835?
Upgrade moodle/moodle to a fixed version for your release line: 2.2.8, 2.3.5 or 2.4.2.
Is CVE-2013-1835 being exploited?
There is no known exploitation of CVE-2013-1835 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as GHSA-cc94-hwj3-rf65, UBUNTU-CVE-2013-1835.