CVE-2013-1836 Moodle does not properly manage privileges for WebDAV repositories
Authenticated users can read, modify, or delete arbitrary site-wide WebDAV repositories due to improper privilege management in Moodle.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2013-1836?
CVE-2013-1836 is a medium-severity missing authorization vulnerability in Moodle Moodle, published on 25 Mar 2013. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Moodle 2.x through 2.1.10, 2.2.x before 2.2.8, 2.3.x before 2.3.5, and 2.4.x before 2.4.2 does not properly manage privileges for WebDAV repositories, which allows remote authenticated users to read, modify, or delete arbitrary site-wide repositories by leveraging certain read access.
Weakness: CWE-264
Which versions are affected by CVE-2013-1836?
6 open source packages ship an affected version, including moodle/moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | From 2.0.0 | 2.2.8 |
moodle/moodle Packagist | From 2.0.0 | 2.2.8 |
moodle/moodle Packagist | From 2.3.0 | 2.3.5 |
moodle/moodle Packagist | From 2.3.0 | 2.3.5 |
moodle/moodle Packagist | From 2.4.0 | 2.4.2 |
moodle/moodle Packagist | From 2.4.0 | 2.4.2 |
Products include Moodle Moodle.
How do I fix CVE-2013-1836?
Upgrade moodle/moodle to a fixed version for your release line: 2.2.8, 2.3.5 or 2.4.2.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2013-1836 being exploited?
There is no known exploitation of CVE-2013-1836 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as GHSA-664q-mrxx-2x2v, UBUNTU-CVE-2013-1836.