CVE-2013-1854 Active Record Improper Input Validation
Remote attackers can cause denial of service in Ruby on Rails applications by sending crafted input to the where method, leading to excessive symbol creation.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2013-1854?
CVE-2013-1854 is a medium-severity denial of service vulnerability in Redhat Enterprise Linux, published on 19 Mar 2013. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
The Active Record component in Ruby on Rails 2.3.x before 2.3.18, 3.1.x before 3.1.12, and 3.2.x before 3.2.13 processes certain queries by converting hash keys to symbols, which allows remote attackers to cause a denial of service via crafted input to a where method.
Weakness: CWE-20
Which versions are affected by CVE-2013-1854?
6 open source packages ship an affected version, including activerecord. It affects 3 products.
| Package | Affected | Fixed in |
|---|---|---|
activerecord RubyGems | From 2.3.0 | 2.3.18 |
activerecord RubyGems | From 2.3.0 | 2.3.18 |
activerecord RubyGems | From 3.1.0 | 3.1.12 |
activerecord RubyGems | From 3.1.0 | 3.1.12 |
activerecord RubyGems | From 3.2.0 | 3.2.13 |
activerecord RubyGems | From 3.2.0 | 3.2.13 |
Linux distribution packages (2)
ruby193-rubygem-activerecord Red Hat:openshift:1::el6 | All versions | 1:3.2.8-6.el6 |
ruby193-rubygem-activerecord-doc Red Hat:openshift:1::el6 | All versions | 1:3.2.8-6.el6 |
Products include Redhat Enterprise Linux, Rubyonrails Rails, Rubyonrails Ruby on Rails.
How do I fix CVE-2013-1854?
Upgrade activerecord to a fixed version for your release line: 2.3.18, 3.1.12 or 3.2.13.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2013-1854 being exploited?
There is no known exploitation of CVE-2013-1854 in the wild and no public exploit code.
Other vulnerabilities in Redhat Enterprise Linux
- CVE-2018-14667 Red Hat JBoss RichFaces Framework Expression Language Injection
- CVE-2021-20325 Missing fixes for CVE-2021-40438 and CVE-2021-26691 in the versions of httpd, as shipped in Red Hat Enterprise Linux 8.5.0, causes a securit
- CVE-2018-25011 Memory corruption in libwebp
- CVE-2018-25014 Other in libwebp
- CVE-2014-3585 Supply chain in redhat-upgrade-tool
Sources
Also known as DEBIAN-CVE-2013-1854, GHSA-3crr-9vmg-864v, RHSA-2013:0699.