{"answers":{"affected":"6 open source packages ship an affected version, including activerecord. It affects 3 products.","exploited":"There is no known exploitation of CVE-2013-1854 in the wild and no public exploit code.","fix":"Upgrade activerecord to a fixed version for your release line: 2.3.18, 3.1.12 or 3.2.13.","what":"CVE-2013-1854 is a medium-severity denial of service vulnerability in Redhat Enterprise Linux, published on 19 Mar 2013. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2013-1854 and fix it if it is affected.\n\nWhat it is: CVE-2013-1854 is a medium-severity denial of service vulnerability in Redhat Enterprise Linux, published on 19 Mar 2013. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2013-1854 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- activerecord (RubyGems): affected from 2.3.0; fixed in 2.3.18\n- activerecord (RubyGems): affected from 2.3.0; fixed in 2.3.18\n- activerecord (RubyGems): affected from 3.1.0; fixed in 3.1.12\n- activerecord (RubyGems): affected from 3.1.0; fixed in 3.1.12\n- activerecord (RubyGems): affected from 3.2.0; fixed in 3.2.13\n- activerecord (RubyGems): affected from 3.2.0; fixed in 3.2.13\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2013-1854/ (Markdown: https://insights.sbomify.com/CVE-2013-1854/index.md)","id":"CVE-2013-1854","markdown":"https://insights.sbomify.com/CVE-2013-1854/index.md","name":"CVE-2013-1854","record":{"aliases":["DEBIAN-CVE-2013-1854","GHSA-3crr-9vmg-864v","RHSA-2013:0699"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby on Rails","requires_auth":"none","summary":"Remote attackers can cause denial of service in Ruby on Rails applications by sending crafted input to the where method, leading to excessive symbol creation.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"enterprise_linux","vendor":"redhat"},{"product":"rails","vendor":"rubyonrails"},{"product":"ruby_on_rails","vendor":"rubyonrails"}],"cvss":{"score":5,"severity":"medium","source":"nvd","vector":"AV:N/AC:L/Au:N/C:N/I:N/A:P","version":"2.0"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"The Active Record component in Ruby on Rails 2.3.x before 2.3.18, 3.1.x before 3.1.12, and 3.2.x before 3.2.13 processes certain queries by converting hash keys to symbols, which allows remote attackers to cause a denial of service via crafted input to a where method.","ecosystems":["Red Hat:openshift:1::el6","RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Active Record Improper Input Validation","id":"CVE-2013-1854","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":"redhat:enterprise_linux","products":["redhat:enterprise_linux","rubyonrails:rails"],"type":"denial_of_service","year":"2013"},"n_packages":8,"n_references":12,"next":{"headline":"actionpack Cross-site Scripting vulnerability","id":"CVE-2013-1855"},"packages":[{"ecosystem":"RubyGems","fixed":["2.3.18"],"introduced":["2.3.0"],"last_affected":[],"package":"activerecord","purl":null,"source":"GHSA-3crr-9vmg-864v"},{"ecosystem":"RubyGems","fixed":["2.3.18"],"introduced":["2.3.0"],"last_affected":[],"package":"activerecord","purl":"pkg:gem/activerecord","source":"GHSA-3crr-9vmg-864v"},{"ecosystem":"RubyGems","fixed":["3.1.12"],"introduced":["3.1.0"],"last_affected":[],"package":"activerecord","purl":null,"source":"GHSA-3crr-9vmg-864v"},{"ecosystem":"RubyGems","fixed":["3.1.12"],"introduced":["3.1.0"],"last_affected":[],"package":"activerecord","purl":"pkg:gem/activerecord","source":"GHSA-3crr-9vmg-864v"},{"ecosystem":"RubyGems","fixed":["3.2.13"],"introduced":["3.2.0"],"last_affected":[],"package":"activerecord","purl":null,"source":"GHSA-3crr-9vmg-864v"},{"ecosystem":"RubyGems","fixed":["3.2.13"],"introduced":["3.2.0"],"last_affected":[],"package":"activerecord","purl":"pkg:gem/activerecord","source":"GHSA-3crr-9vmg-864v"},{"ecosystem":"Red Hat:openshift:1::el6","fixed":["1:3.2.8-6.el6"],"introduced":["0"],"last_affected":[],"package":"ruby193-rubygem-activerecord","purl":"pkg:rpm/redhat/ruby193-rubygem-activerecord","source":"RHSA-2013:0699"},{"ecosystem":"Red Hat:openshift:1::el6","fixed":["1:3.2.8-6.el6"],"introduced":["0"],"last_affected":[],"package":"ruby193-rubygem-activerecord-doc","purl":"pkg:rpm/redhat/ruby193-rubygem-activerecord-doc","source":"RHSA-2013:0699"}],"prev":{"headline":"Information disclosure in n/a","id":"CVE-2013-1853"},"products":["n/a"],"published":"2013-03-19","related":[{"cvss_score":9.8,"headline":"Red Hat JBoss RichFaces Framework Expression Language Injection","id":"CVE-2018-14667","kev_date_added":"2023-09-28","published":"2018-11-06"},{"cvss_score":9.8,"headline":"Missing fixes for CVE-2021-40438 and CVE-2021-26691 in the versions of httpd, as shipped in Red Hat Enterprise Linux 8.5.0, causes a securit","id":"CVE-2021-20325","kev_date_added":null,"published":"2022-02-18"},{"cvss_score":9.8,"headline":"Memory corruption in libwebp","id":"CVE-2018-25011","kev_date_added":null,"published":"2021-05-21"},{"cvss_score":9.8,"headline":"Other in libwebp","id":"CVE-2018-25014","kev_date_added":null,"published":"2021-05-21"},{"cvss_score":9.8,"headline":"Supply chain in redhat-upgrade-tool","id":"CVE-2014-3585","kev_date_added":null,"published":"2019-11-22"},{"cvss_score":9.3,"headline":"Squid: request/response smuggling in http/1.1 and icap","id":"CVE-2023-46846","kev_date_added":null,"published":"2023-11-03"},{"cvss_score":9.1,"headline":"Memory corruption in libwebp","id":"CVE-2018-25009","kev_date_added":null,"published":"2021-05-21"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Red Hat","prefix":"RHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can cause denial of service in Ruby on Rails applications by sending crafted input to the where method, leading to excessive symbol creation.","url":"https://insights.sbomify.com/CVE-2013-1854/"}