# CVE-2013-1854: Active Record Improper Input Validation

> Remote attackers can cause denial of service in Ruby on Rails applications by sending crafted input to the where method, leading to excessive symbol creation.

- **Severity:** Medium 5.0 (`AV:N/AC:L/Au:N/C:N/I:N/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Mar 2013
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2013-1854, GHSA-3crr-9vmg-864v, RHSA-2013:0699

## What is CVE-2013-1854?

CVE-2013-1854 is a medium-severity denial of service vulnerability in Redhat Enterprise Linux, published on 19 Mar 2013. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The Active Record component in Ruby on Rails 2.3.x before 2.3.18, 3.1.x before 3.1.12, and 3.2.x before 3.2.13 processes certain queries by converting hash keys to symbols, which allows remote attackers to cause a denial of service via crafted input to a where method.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2013-1854?

6 open source packages ship an affected version, including activerecord. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `activerecord` | RubyGems | From 2.3.0 | 2.3.18 |
| `activerecord` | RubyGems | From 2.3.0 | 2.3.18 |
| `activerecord` | RubyGems | From 3.1.0 | 3.1.12 |
| `activerecord` | RubyGems | From 3.1.0 | 3.1.12 |
| `activerecord` | RubyGems | From 3.2.0 | 3.2.13 |
| `activerecord` | RubyGems | From 3.2.0 | 3.2.13 |
| `ruby193-rubygem-activerecord` | Red Hat:openshift:1::el6 | All versions | 1:3.2.8-6.el6 |
| `ruby193-rubygem-activerecord-doc` | Red Hat:openshift:1::el6 | All versions | 1:3.2.8-6.el6 |

Products: Redhat Enterprise Linux, Rubyonrails Rails, Rubyonrails Ruby on Rails.

## How do I fix CVE-2013-1854?

Upgrade activerecord to a fixed version for your release line: 2.3.18, 3.1.12 or 3.2.13.

## Is CVE-2013-1854 being exploited?

There is no known exploitation of CVE-2013-1854 in the wild and no public exploit code.

## Other vulnerabilities in Redhat Enterprise Linux

- [CVE-2018-14667](https://insights.sbomify.com/CVE-2018-14667/): Red Hat JBoss RichFaces Framework Expression Language Injection (critical 9.8, exploited in the wild)
- [CVE-2021-20325](https://insights.sbomify.com/CVE-2021-20325/): Missing fixes for CVE-2021-40438 and CVE-2021-26691 in the versions of httpd, as shipped in Red Hat Enterprise Linux 8.5.0, causes a securit (critical 9.8)
- [CVE-2018-25011](https://insights.sbomify.com/CVE-2018-25011/): Memory corruption in libwebp (critical 9.8)
- [CVE-2018-25014](https://insights.sbomify.com/CVE-2018-25014/): Other in libwebp (critical 9.8)
- [CVE-2014-3585](https://insights.sbomify.com/CVE-2014-3585/): Supply chain in redhat-upgrade-tool (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2013-1854 and fix it if it is affected.

What it is: CVE-2013-1854 is a medium-severity denial of service vulnerability in Redhat Enterprise Linux, published on 19 Mar 2013. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2013-1854 in the wild and no public exploit code.

Affected packages and fixed versions:
- activerecord (RubyGems): affected from 2.3.0; fixed in 2.3.18
- activerecord (RubyGems): affected from 2.3.0; fixed in 2.3.18
- activerecord (RubyGems): affected from 3.1.0; fixed in 3.1.12
- activerecord (RubyGems): affected from 3.1.0; fixed in 3.1.12
- activerecord (RubyGems): affected from 3.2.0; fixed in 3.2.13
- activerecord (RubyGems): affected from 3.2.0; fixed in 3.2.13

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2013-1854/ (Markdown: https://insights.sbomify.com/CVE-2013-1854/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2013-1854
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2013-1854
- OSV: https://osv.dev/vulnerability/CVE-2013-1854

---
From sbomify Insights: https://insights.sbomify.com/CVE-2013-1854/
Summaries are generated and may contain mistakes; the official description above is the record.
