{"answers":{"affected":"6 open source packages ship an affected version, including actionpack. It affects 3 products.","exploited":"There is no known exploitation of CVE-2013-1855 in the wild and no public exploit code.","fix":"Upgrade actionpack to a fixed version for your release line: 2.3.18, 3.1.12 or 3.2.13.","what":"CVE-2013-1855 is a medium-severity cross-site scripting vulnerability in Redhat Enterprise Linux, published on 19 Mar 2013. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2013-1855 and fix it if it is affected.\n\nWhat it is: CVE-2013-1855 is a medium-severity cross-site scripting vulnerability in Redhat Enterprise Linux, published on 19 Mar 2013. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2013-1855 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- actionpack (RubyGems): affected all versions; fixed in 2.3.18\n- actionpack (RubyGems): affected all versions; fixed in 2.3.18\n- actionpack (RubyGems): affected from 3.0.0; fixed in 3.1.12\n- actionpack (RubyGems): affected from 3.0.0; fixed in 3.1.12\n- actionpack (RubyGems): affected from 3.2.0; fixed in 3.2.13\n- actionpack (RubyGems): affected from 3.2.0; fixed in 3.2.13\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2013-1855/ (Markdown: https://insights.sbomify.com/CVE-2013-1855/index.md)","id":"CVE-2013-1855","markdown":"https://insights.sbomify.com/CVE-2013-1855/index.md","name":"CVE-2013-1855","record":{"aliases":["DEBIAN-CVE-2013-1855","GHSA-q759-hwvc-m3jg"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby on Rails","requires_auth":"none","summary":"Remote attackers can execute cross-site scripting attacks via crafted CSS tokens due to improper newline handling in the sanitizer.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"enterprise_linux","vendor":"redhat"},{"product":"rails","vendor":"rubyonrails"},{"product":"ruby_on_rails","vendor":"rubyonrails"}],"cvss":{"score":4.3,"severity":"medium","source":"nvd","vector":"AV:N/AC:M/Au:N/C:N/I:P/A:N","version":"2.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"The sanitize_css method in lib/action_controller/vendor/html-scanner/html/sanitizer.rb in the Action Pack component in Ruby on Rails before 2.3.18, 3.0.x and 3.1.x before 3.1.12, and 3.2.x before 3.2.13 does not properly handle \\n (newline) characters, which makes it easier for remote attackers to conduct cross-site scripting (XSS) attacks via crafted Cascading Style Sheets (CSS) token sequences.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"actionpack Cross-site Scripting vulnerability","id":"CVE-2013-1855","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":"redhat:enterprise_linux","products":["redhat:enterprise_linux","rubyonrails:rails"],"type":"xss","year":"2013"},"n_packages":6,"n_references":10,"next":{"headline":"activesupport Improper Input Validation vulnerability","id":"CVE-2013-1856"},"packages":[{"ecosystem":"RubyGems","fixed":["2.3.18"],"introduced":["0"],"last_affected":[],"package":"actionpack","purl":null,"source":"GHSA-q759-hwvc-m3jg"},{"ecosystem":"RubyGems","fixed":["2.3.18"],"introduced":["0"],"last_affected":[],"package":"actionpack","purl":"pkg:gem/actionpack","source":"GHSA-q759-hwvc-m3jg"},{"ecosystem":"RubyGems","fixed":["3.1.12"],"introduced":["3.0.0"],"last_affected":[],"package":"actionpack","purl":null,"source":"GHSA-q759-hwvc-m3jg"},{"ecosystem":"RubyGems","fixed":["3.1.12"],"introduced":["3.0.0"],"last_affected":[],"package":"actionpack","purl":"pkg:gem/actionpack","source":"GHSA-q759-hwvc-m3jg"},{"ecosystem":"RubyGems","fixed":["3.2.13"],"introduced":["3.2.0"],"last_affected":[],"package":"actionpack","purl":null,"source":"GHSA-q759-hwvc-m3jg"},{"ecosystem":"RubyGems","fixed":["3.2.13"],"introduced":["3.2.0"],"last_affected":[],"package":"actionpack","purl":"pkg:gem/actionpack","source":"GHSA-q759-hwvc-m3jg"}],"prev":{"headline":"Active Record Improper Input Validation","id":"CVE-2013-1854"},"products":["n/a"],"published":"2013-03-19","related":[{"cvss_score":9.8,"headline":"Red Hat JBoss RichFaces Framework Expression Language Injection","id":"CVE-2018-14667","kev_date_added":"2023-09-28","published":"2018-11-06"},{"cvss_score":9.8,"headline":"Missing fixes for CVE-2021-40438 and CVE-2021-26691 in the versions of httpd, as shipped in Red Hat Enterprise Linux 8.5.0, causes a securit","id":"CVE-2021-20325","kev_date_added":null,"published":"2022-02-18"},{"cvss_score":9.8,"headline":"Memory corruption in libwebp","id":"CVE-2018-25011","kev_date_added":null,"published":"2021-05-21"},{"cvss_score":9.8,"headline":"Other in libwebp","id":"CVE-2018-25014","kev_date_added":null,"published":"2021-05-21"},{"cvss_score":9.8,"headline":"Supply chain in redhat-upgrade-tool","id":"CVE-2014-3585","kev_date_added":null,"published":"2019-11-22"},{"cvss_score":9.3,"headline":"Squid: request/response smuggling in http/1.1 and icap","id":"CVE-2023-46846","kev_date_added":null,"published":"2023-11-03"},{"cvss_score":9.1,"headline":"Memory corruption in libwebp","id":"CVE-2018-25009","kev_date_added":null,"published":"2021-05-21"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can execute cross-site scripting attacks via crafted CSS tokens due to improper newline handling in the sanitizer.","url":"https://insights.sbomify.com/CVE-2013-1855/"}