CVE-2013-1856 activesupport Improper Input Validation vulnerability

Medium 5.8 Published Updated

Remote attackers can read arbitrary files or cause denial of service via XML external entity attacks in Ruby on Rails when using JRuby.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2013-1856?

CVE-2013-1856 is a medium-severity vulnerability in Rubyonrails Rails, published on 19 Mar 2013. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

The ActiveSupport::XmlMini_JDOM backend in lib/active_support/xml_mini/jdom.rb in the Active Support component in Ruby on Rails 3.0.x and 3.1.x before 3.1.12 and 3.2.x before 3.2.13, when JRuby is used, does not properly restrict the capabilities of the XML parser, which allows remote attackers to read arbitrary files or cause a denial of service (resource consumption) via vectors involving (1) an external DTD or (2) an external entity declaration in conjunction with an entity reference.

Weakness: CWE-20

Which versions are affected by CVE-2013-1856?

4 open source packages ship an affected version, including activesupport. It affects 2 products.

PackageAffectedFixed in
activesupport RubyGemsFrom 3.0.03.1.12
activesupport RubyGemsFrom 3.0.03.1.12
activesupport RubyGemsFrom 3.2.03.2.13
activesupport RubyGemsFrom 3.2.03.2.13

Products include Rubyonrails Rails, Rubyonrails Ruby on Rails.

How do I fix CVE-2013-1856?

Upgrade activesupport to a fixed version for your release line: 3.1.12 or 3.2.13.

Is CVE-2013-1856 being exploited?

There is no known exploitation of CVE-2013-1856 in the wild and no public exploit code.

All Rubyonrails Rails vulnerabilities

Sources

Also known as GHSA-9c2j-593q-3g82.

Is CVE-2013-1856 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free