# CVE-2013-1857: actionpack Cross-site Scripting vulnerability

> Remote attackers can execute cross-site scripting attacks via crafted URLs with encoded colons in Ruby on Rails applications.

- **Severity:** Medium 4.3 (`AV:N/AC:M/Au:N/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 19 Mar 2013
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2013-1857, GHSA-j838-vfpq-fmf2

## What is CVE-2013-1857?

CVE-2013-1857 is a medium-severity cross-site scripting vulnerability in Redhat Enterprise Linux, published on 19 Mar 2013. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

The sanitize helper in lib/action_controller/vendor/html-scanner/html/sanitizer.rb in the Action Pack component in Ruby on Rails before 2.3.18, 3.0.x and 3.1.x before 3.1.12, and 3.2.x before 3.2.13 does not properly handle encoded : (colon) characters in URLs, which makes it easier for remote attackers to conduct cross-site scripting (XSS) attacks via a crafted scheme name, as demonstrated by including a &#x3a; sequence.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2013-1857?

6 open source packages ship an affected version, including actionpack. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `actionpack` | RubyGems | All versions | 2.3.18 |
| `actionpack` | RubyGems | All versions | 2.3.18 |
| `actionpack` | RubyGems | From 3.0.0 | 3.1.12 |
| `actionpack` | RubyGems | From 3.0.0 | 3.1.12 |
| `actionpack` | RubyGems | From 3.2.0 | 3.2.13 |
| `actionpack` | RubyGems | From 3.2.0 | 3.2.13 |

Products: Redhat Enterprise Linux, Rubyonrails Rails, Rubyonrails Ruby on Rails.

## How do I fix CVE-2013-1857?

Upgrade actionpack to a fixed version for your release line: 2.3.18, 3.1.12 or 3.2.13.

## Is CVE-2013-1857 being exploited?

There is no known exploitation of CVE-2013-1857 in the wild and no public exploit code.

## Other vulnerabilities in Redhat Enterprise Linux

- [CVE-2018-14667](https://insights.sbomify.com/CVE-2018-14667/): Red Hat JBoss RichFaces Framework Expression Language Injection (critical 9.8, exploited in the wild)
- [CVE-2021-20325](https://insights.sbomify.com/CVE-2021-20325/): Missing fixes for CVE-2021-40438 and CVE-2021-26691 in the versions of httpd, as shipped in Red Hat Enterprise Linux 8.5.0, causes a securit (critical 9.8)
- [CVE-2018-25011](https://insights.sbomify.com/CVE-2018-25011/): Memory corruption in libwebp (critical 9.8)
- [CVE-2018-25014](https://insights.sbomify.com/CVE-2018-25014/): Other in libwebp (critical 9.8)
- [CVE-2014-3585](https://insights.sbomify.com/CVE-2014-3585/): Supply chain in redhat-upgrade-tool (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2013-1857 and fix it if it is affected.

What it is: CVE-2013-1857 is a medium-severity cross-site scripting vulnerability in Redhat Enterprise Linux, published on 19 Mar 2013. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2013-1857 in the wild and no public exploit code.

Affected packages and fixed versions:
- actionpack (RubyGems): affected all versions; fixed in 2.3.18
- actionpack (RubyGems): affected all versions; fixed in 2.3.18
- actionpack (RubyGems): affected from 3.0.0; fixed in 3.1.12
- actionpack (RubyGems): affected from 3.0.0; fixed in 3.1.12
- actionpack (RubyGems): affected from 3.2.0; fixed in 3.2.13
- actionpack (RubyGems): affected from 3.2.0; fixed in 3.2.13

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2013-1857/ (Markdown: https://insights.sbomify.com/CVE-2013-1857/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2013-1857
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2013-1857
- OSV: https://osv.dev/vulnerability/CVE-2013-1857

---
From sbomify Insights: https://insights.sbomify.com/CVE-2013-1857/
Summaries are generated and may contain mistakes; the official description above is the record.
