# CVE-2013-1865: OpenStack Keystone Improper Authentication vulnerability

> Remote attackers can bypass access restrictions in OpenStack Keystone by using revoked PKI tokens, allowing unauthorized access to protected resources.

- **Severity:** Medium 6.8 (`AV:N/AC:M/Au:N/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Mar 2013
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-22q6-wwq7-2jj9, PYSEC-2013-39

## What is CVE-2013-1865?

CVE-2013-1865 is a medium-severity authentication bypass vulnerability in Canonical Ubuntu Linux, published on 22 Mar 2013. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

OpenStack Keystone Folsom (2012.2) does not properly perform revocation checks for Keystone PKI tokens when done through a server, which allows remote attackers to bypass intended access restrictions via a revoked PKI token.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2013-1865?

3 open source packages ship an affected version, including keystone. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `keystone` | PyPI | From 2012.2 | 2012.2.4 |
| `keystone` | PyPI | From 2012.2 | 2012.2.4 |
| `keystone` | PyPI | From 2012.2 | 2012.2.4 |

Products: Canonical Ubuntu Linux, Openstack Folsom.

## How do I fix CVE-2013-1865?

Upgrade keystone to 2012.2.4 or later.

## Is CVE-2013-1865 being exploited?

There is no known exploitation of CVE-2013-1865 in the wild and no public exploit code.

## Other vulnerabilities in Canonical Ubuntu Linux

- [CVE-2020-11651](https://insights.sbomify.com/CVE-2020-11651/): SaltStack Salt Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-7247](https://insights.sbomify.com/CVE-2020-7247/): OpenSMTPD Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2019-16928](https://insights.sbomify.com/CVE-2019-16928/): Exim Out-of-bounds Write (critical 9.8, exploited in the wild)
- [CVE-2018-6789](https://insights.sbomify.com/CVE-2018-6789/): Exim Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2015-2590](https://insights.sbomify.com/CVE-2015-2590/): Oracle Java SE and Java SE Embedded Remote Code Execution (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2013-1865 and fix it if it is affected.

What it is: CVE-2013-1865 is a medium-severity authentication bypass vulnerability in Canonical Ubuntu Linux, published on 22 Mar 2013. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2013-1865 in the wild and no public exploit code.

Affected packages and fixed versions:
- keystone (PyPI): affected from 2012.2; fixed in 2012.2.4
- keystone (PyPI): affected from 2012.2; fixed in 2012.2.4
- keystone (PyPI): affected from 2012.2; fixed in 2012.2.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2013-1865/ (Markdown: https://insights.sbomify.com/CVE-2013-1865/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2013-1865
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2013-1865
- OSV: https://osv.dev/vulnerability/CVE-2013-1865

---
From sbomify Insights: https://insights.sbomify.com/CVE-2013-1865/
Summaries are generated and may contain mistakes; the official description above is the record.
