# CVE-2013-1880: Apache ActiveMQ Cross-site scripting (XSS) vulnerability in the Portfolio publisher servlet

> Remote attackers can inject arbitrary web script via the refresh parameter in the demo web application, requiring user interaction to execute.

- **Severity:** Medium 4.3 (`AV:N/AC:M/Au:N/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 5 Feb 2014
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-c9gx-27hq-wcvj

## What is CVE-2013-1880?

CVE-2013-1880 is a medium-severity cross-site scripting vulnerability in Apache Activemq, published on 5 Feb 2014. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Cross-site scripting (XSS) vulnerability in the Portfolio publisher servlet in the demo web application in Apache ActiveMQ before 5.9.0 allows remote attackers to inject arbitrary web script or HTML via the refresh parameter to demo/portfolioPublish, a different vulnerability than CVE-2012-6092.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2013-1880?

2 open source packages ship an affected version, including org.apache.activemq:activemq-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.activemq:activemq-core` | Maven | All versions | 5.9.0 |
| `org.apache.activemq:activemq-core` | Maven | All versions | 5.9.0 |

Products: Apache Activemq.

## How do I fix CVE-2013-1880?

Upgrade org.apache.activemq:activemq-core to 5.9.0 or later.

## Is CVE-2013-1880 being exploited?

There is no known exploitation of CVE-2013-1880 in the wild and no public exploit code.

## Other vulnerabilities in Apache Activemq

- [CVE-2023-46604](https://insights.sbomify.com/CVE-2023-46604/): Apache ActiveMQ Deserialization of Untrusted Data (critical 10.0, exploited in the wild)
- [CVE-2016-3088](https://insights.sbomify.com/CVE-2016-3088/): Apache ActiveMQ Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2026-34197](https://insights.sbomify.com/CVE-2026-34197/): Apache ActiveMQ Improper Input Validation (high 8.8, exploited in the wild)
- [CVE-2020-11998](https://insights.sbomify.com/CVE-2020-11998/): Remote code execution in Apache ActiveMQ (critical 9.8)
- [CVE-2013-7285](https://insights.sbomify.com/CVE-2013-7285/): Command Injection in Xstream (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2013-1880 and fix it if it is affected.

What it is: CVE-2013-1880 is a medium-severity cross-site scripting vulnerability in Apache Activemq, published on 5 Feb 2014. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2013-1880 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.activemq:activemq-core (Maven): affected all versions; fixed in 5.9.0
- org.apache.activemq:activemq-core (Maven): affected all versions; fixed in 5.9.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2013-1880/ (Markdown: https://insights.sbomify.com/CVE-2013-1880/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2013-1880
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2013-1880
- OSV: https://osv.dev/vulnerability/CVE-2013-1880

---
From sbomify Insights: https://insights.sbomify.com/CVE-2013-1880/
Summaries are generated and may contain mistakes; the official description above is the record.
