{"answers":{"affected":"3 open source packages ship an affected version, including pip. It affects 2 products.","exploited":"There is no known exploitation of CVE-2013-1888 in the wild and no public exploit code.","fix":"Upgrade pip to 1.3 or later.","what":"CVE-2013-1888 is a low-severity path traversal vulnerability in Fedoraproject Fedora, published on 16 Aug 2013. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2013-1888 and fix it if it is affected.\n\nWhat it is: CVE-2013-1888 is a low-severity path traversal vulnerability in Fedoraproject Fedora, published on 16 Aug 2013. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2013-1888 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pip (PyPI): affected all versions; fixed in 1.3\n- pip (PyPI): affected all versions; fixed in 1.3\n- pip (PyPI): affected all versions; fixed in 1.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2013-1888/ (Markdown: https://insights.sbomify.com/CVE-2013-1888/index.md)","id":"CVE-2013-1888","markdown":"https://insights.sbomify.com/CVE-2013-1888/index.md","name":"CVE-2013-1888","record":{"aliases":["GHSA-4gv5-qhvr-36vv","PYSEC-2013-9"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["data_modify"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Python package installer","requires_auth":"none","summary":"Local attackers can overwrite arbitrary files via symlink attacks in pip's temporary build directory, potentially compromising system integrity.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"fedora","vendor":"fedoraproject"},{"product":"pip","vendor":"pypa"}],"cvss":{"score":2.1,"severity":"low","source":"nvd","vector":"AV:L/AC:L/Au:N/C:N/I:P/A:N","version":"2.0"},"cwes":[{"id":"CWE-59","name":"Improper Link Resolution Before File Access"}],"description":"pip before 1.3 allows local users to overwrite arbitrary files via a symlink attack on a file in the /tmp/pip-build temporary directory.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Improper Link Resolution Before File Access in pip","id":"CVE-2013-1888","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":"fedoraproject:fedora","products":["fedoraproject:fedora"],"type":"path_traversal","year":"2013"},"n_packages":3,"n_references":7,"next":{"headline":"Security feature bypass in libapache2-mod-ruid2","id":"CVE-2013-1889"},"packages":[{"ecosystem":"PyPI","fixed":["1.3"],"introduced":["0"],"last_affected":[],"package":"pip","purl":null,"source":"GHSA-4gv5-qhvr-36vv"},{"ecosystem":"PyPI","fixed":["1.3"],"introduced":["0"],"last_affected":[],"package":"pip","purl":"pkg:pypi/pip","source":"GHSA-4gv5-qhvr-36vv"},{"ecosystem":"PyPI","fixed":["1.3"],"introduced":["0"],"last_affected":[],"package":"pip","purl":"pkg:pypi/pip","source":"PYSEC-2013-9"}],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2013-1887"},"products":["n/a"],"published":"2013-08-16","related":[{"cvss_score":9.8,"headline":"PHP-CGI OS Command Injection","id":"CVE-2024-4577","kev_date_added":"2024-06-12","published":"2024-06-09"},{"cvss_score":9.8,"headline":"Grafana Authentication Bypass","id":"CVE-2021-39226","kev_date_added":"2022-08-25","published":"2021-10-05"},{"cvss_score":9.8,"headline":"VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow","id":"CVE-2019-5544","kev_date_added":"2021-11-03","published":"2019-12-06"},{"cvss_score":9.6,"headline":"Google Chromium V8 Type Confusion","id":"CVE-2024-4947","kev_date_added":"2024-05-20","published":"2024-05-15"},{"cvss_score":9.6,"headline":"Google Chromium Visuals Use-After-Free","id":"CVE-2024-4671","kev_date_added":"2024-05-13","published":"2024-05-09"},{"cvss_score":9.6,"headline":"Google Chromium Mojo Insufficient Data Validation","id":"CVE-2022-3075","kev_date_added":"2022-09-08","published":"2022-09-26"},{"cvss_score":9.6,"headline":"Google Chromium Indexed DB API Use-After-Free","id":"CVE-2021-30633","kev_date_added":"2021-11-03","published":"2021-10-08"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Local attackers can overwrite arbitrary files via symlink attacks in pip's temporary build directory, potentially compromising system integrity.","url":"https://insights.sbomify.com/CVE-2013-1888/"}