# CVE-2013-1909: Apache Qpid Python client Improper certificate validation

> Man-in-the-middle attackers can spoof SSL servers because the Python client fails to verify hostname against certificate CN or subjectAltName.

- **Severity:** Medium 5.8 (`AV:N/AC:M/Au:N/C:P/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Aug 2013
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-3g2p-7c6p-vj8c, PYSEC-2013-25, RHSA-2013:1024

## What is CVE-2013-1909?

CVE-2013-1909 is a medium-severity vulnerability in Redhat Enterprise Mrg, published on 23 Aug 2013. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The Python client in Apache Qpid before 2.2 does not verify that the server hostname matches a domain name in the subject's Common Name (CN) or subjectAltName field of the X.509 certificate, which allows man-in-the-middle attackers to spoof SSL servers via an arbitrary valid certificate.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2013-1909?

3 open source packages ship an affected version, including qpid-python. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `qpid-python` | PyPI | All versions | 0.22 |
| `qpid-python` | PyPI | All versions | 0.22 |
| `qpid-python` | PyPI | All versions | 0.22 |
| `python-qpid` | Red Hat:enterprise_mrg:2:computenode:el6 | All versions | 0:0.18-5.el6_4 |
| `python-qpid-qmf` | Red Hat:enterprise_mrg:2:computenode:el6 | All versions | 0:0.18-18.el6_4 |
| `qpid-cpp` | Red Hat:enterprise_mrg:2:computenode:el6 | All versions | 0:0.18-17.el6_4 |
| `qpid-cpp-client` | Red Hat:enterprise_mrg:2:computenode:el6 | All versions | 0:0.18-17.el6_4 |
| `qpid-cpp-client-ssl` | Red Hat:enterprise_mrg:2:computenode:el6 | All versions | 0:0.18-17.el6_4 |
| `qpid-cpp-debuginfo` | Red Hat:enterprise_mrg:2:computenode:el6 | All versions | 0:0.18-17.el6_4 |
| `qpid-cpp-server` | Red Hat:enterprise_mrg:2:computenode:el6 | All versions | 0:0.18-17.el6_4 |
| `qpid-cpp-server-ssl` | Red Hat:enterprise_mrg:2:computenode:el6 | All versions | 0:0.18-17.el6_4 |
| `qpid-qmf` | Red Hat:enterprise_mrg:2:computenode:el6 | All versions | 0:0.18-18.el6_4 |
| `qpid-qmf-debuginfo` | Red Hat:enterprise_mrg:2:computenode:el6 | All versions | 0:0.18-18.el6_4 |
| `qpid-tools` | Red Hat:enterprise_mrg:2:computenode:el6 | All versions | 0:0.18-10.el6_4 |
| `ruby-qpid-qmf` | Red Hat:enterprise_mrg:2:computenode:el6 | All versions | 0:0.18-18.el6_4 |
| `python-qpid` | Red Hat:enterprise_mrg:2:server:el6 | All versions | 0:0.18-5.el6_4 |
| `python-qpid-qmf` | Red Hat:enterprise_mrg:2:server:el6 | All versions | 0:0.18-18.el6_4 |
| `qpid-cpp` | Red Hat:enterprise_mrg:2:server:el6 | All versions | 0:0.18-17.el6_4 |
| `qpid-cpp-client` | Red Hat:enterprise_mrg:2:server:el6 | All versions | 0:0.18-17.el6_4 |
| `qpid-cpp-client-devel` | Red Hat:enterprise_mrg:2:server:el6 | All versions | 0:0.18-17.el6_4 |
| `qpid-cpp-client-devel-docs` | Red Hat:enterprise_mrg:2:server:el6 | All versions | 0:0.18-17.el6_4 |
| `qpid-cpp-client-rdma` | Red Hat:enterprise_mrg:2:server:el6 | All versions | 0:0.18-17.el6_4 |
| `qpid-cpp-client-ssl` | Red Hat:enterprise_mrg:2:server:el6 | All versions | 0:0.18-17.el6_4 |
| `qpid-cpp-debuginfo` | Red Hat:enterprise_mrg:2:server:el6 | All versions | 0:0.18-17.el6_4 |
| `qpid-cpp-server` | Red Hat:enterprise_mrg:2:server:el6 | All versions | 0:0.18-17.el6_4 |
| `qpid-cpp-server-cluster` | Red Hat:enterprise_mrg:2:server:el6 | All versions | 0:0.18-17.el6_4 |
| `qpid-cpp-server-devel` | Red Hat:enterprise_mrg:2:server:el6 | All versions | 0:0.18-17.el6_4 |
| `qpid-cpp-server-rdma` | Red Hat:enterprise_mrg:2:server:el6 | All versions | 0:0.18-17.el6_4 |
| `qpid-cpp-server-ssl` | Red Hat:enterprise_mrg:2:server:el6 | All versions | 0:0.18-17.el6_4 |
| `qpid-cpp-server-store` | Red Hat:enterprise_mrg:2:server:el6 | All versions | 0:0.18-17.el6_4 |
| `qpid-cpp-server-xml` | Red Hat:enterprise_mrg:2:server:el6 | All versions | 0:0.18-17.el6_4 |
| `qpid-java` | Red Hat:enterprise_mrg:2:server:el6 | All versions | 0:0.18-8.el6_4 |
| `qpid-java-client` | Red Hat:enterprise_mrg:2:server:el6 | All versions | 0:0.18-8.el6_4 |
| `qpid-java-common` | Red Hat:enterprise_mrg:2:server:el6 | All versions | 0:0.18-8.el6_4 |
| `qpid-java-example` | Red Hat:enterprise_mrg:2:server:el6 | All versions | 0:0.18-8.el6_4 |
| `qpid-qmf` | Red Hat:enterprise_mrg:2:server:el6 | All versions | 0:0.18-18.el6_4 |
| `qpid-qmf-debuginfo` | Red Hat:enterprise_mrg:2:server:el6 | All versions | 0:0.18-18.el6_4 |
| `qpid-qmf-devel` | Red Hat:enterprise_mrg:2:server:el6 | All versions | 0:0.18-18.el6_4 |
| `qpid-tools` | Red Hat:enterprise_mrg:2:server:el6 | All versions | 0:0.18-10.el6_4 |
| `ruby-qpid-qmf` | Red Hat:enterprise_mrg:2:server:el6 | All versions | 0:0.18-18.el6_4 |

Products: Apache Qpid, Redhat Enterprise Mrg.

## How do I fix CVE-2013-1909?

Upgrade qpid-python to 0.22 or later.

## Is CVE-2013-1909 being exploited?

There is no known exploitation of CVE-2013-1909 in the wild and no public exploit code.

## Other vulnerabilities in Redhat Enterprise Mrg

- [CVE-2015-0224](https://insights.sbomify.com/CVE-2015-0224/): Denial of service in n/a (high 7.5)
- [CVE-2011-3620](https://insights.sbomify.com/CVE-2011-3620/): Auth bypass in n/a (high 7.5)
- [CVE-2019-0223](https://insights.sbomify.com/CVE-2019-0223/): Security feature bypass in Apache Qpid Proton (high 7.4)
- [CVE-2012-4446](https://insights.sbomify.com/CVE-2012-4446/): Improper Authentication in Apache Qpid (medium 6.8)
- [CVE-2015-0203](https://insights.sbomify.com/CVE-2015-0203/): Denial of service in n/a (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2013-1909 and fix it if it is affected.

What it is: CVE-2013-1909 is a medium-severity vulnerability in Redhat Enterprise Mrg, published on 23 Aug 2013. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2013-1909 in the wild and no public exploit code.

Affected packages and fixed versions:
- qpid-python (PyPI): affected all versions; fixed in 0.22
- qpid-python (PyPI): affected all versions; fixed in 0.22
- qpid-python (PyPI): affected all versions; fixed in 0.22

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2013-1909/ (Markdown: https://insights.sbomify.com/CVE-2013-1909/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2013-1909
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2013-1909
- OSV: https://osv.dev/vulnerability/CVE-2013-1909

---
From sbomify Insights: https://insights.sbomify.com/CVE-2013-1909/
Summaries are generated and may contain mistakes; the official description above is the record.
