CVE-2013-1939 SabreDAV Directory Traversal vulnerability
Remote attackers can read arbitrary files on Windows systems by exploiting improper path separator checks in the SabreDAV HTML Browser plugin.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2013-1939?
CVE-2013-1939 is a medium-severity path traversal vulnerability in Owncloud Owncloud Server, published on 14 Mar 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
The HTML\Browser plugin in SabreDAV before 1.6.9, 1.7.x before 1.7.7, and 1.8.x before 1.8.5, as used in ownCloud, when running on Windows, does not properly check path separators in the base path, which allows remote attackers to read arbitrary files via a \ (backslash) character.
Weakness: CWE-20
Which versions are affected by CVE-2013-1939?
6 open source packages ship an affected version, including sabre/dav. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
sabre/dav Packagist | From 1.6.0 | 1.6.9 |
sabre/dav Packagist | From 1.6.0 | 1.6.9 |
sabre/dav Packagist | From 1.7.0 | 1.7.7 |
sabre/dav Packagist | From 1.7.0 | 1.7.7 |
sabre/dav Packagist | From 1.8.0 | 1.8.5 |
sabre/dav Packagist | From 1.8.0 | 1.8.5 |
Products include Fruux Sabredav, Owncloud Owncloud Server.
How do I fix CVE-2013-1939?
Upgrade sabre/dav to a fixed version for your release line: 1.6.9, 1.7.7 or 1.8.5.
Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.
Is CVE-2013-1939 being exploited?
There is no known exploitation of CVE-2013-1939 in the wild and no public exploit code.
Other vulnerabilities in Owncloud Owncloud Server
Sources
Also known as GHSA-qg5v-jw6f-rpfj.