{"answers":{"affected":"6 open source packages ship an affected version, including sabre/dav. It affects 2 products.","exploited":"There is no known exploitation of CVE-2013-1939 in the wild and no public exploit code.","fix":"Upgrade sabre/dav to a fixed version for your release line: 1.6.9, 1.7.7 or 1.8.5.","what":"CVE-2013-1939 is a medium-severity path traversal vulnerability in Owncloud Owncloud Server, published on 14 Mar 2014. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2013-1939 and fix it if it is affected.\n\nWhat it is: CVE-2013-1939 is a medium-severity path traversal vulnerability in Owncloud Owncloud Server, published on 14 Mar 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2013-1939 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- sabre/dav (Packagist): affected from 1.6.0; fixed in 1.6.9\n- sabre/dav (Packagist): affected from 1.6.0; fixed in 1.6.9\n- sabre/dav (Packagist): affected from 1.7.0; fixed in 1.7.7\n- sabre/dav (Packagist): affected from 1.7.0; fixed in 1.7.7\n- sabre/dav (Packagist): affected from 1.8.0; fixed in 1.8.5\n- sabre/dav (Packagist): affected from 1.8.0; fixed in 1.8.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2013-1939/ (Markdown: https://insights.sbomify.com/CVE-2013-1939/index.md)","id":"CVE-2013-1939","markdown":"https://insights.sbomify.com/CVE-2013-1939/index.md","name":"CVE-2013-1939","record":{"aliases":["GHSA-qg5v-jw6f-rpfj"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"WebDAV server","requires_auth":"none","summary":"Remote attackers can read arbitrary files on Windows systems by exploiting improper path separator checks in the SabreDAV HTML Browser plugin.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"sabredav","vendor":"fruux"},{"product":"owncloud_server","vendor":"owncloud"}],"cvss":{"score":5,"severity":"medium","source":"nvd","vector":"AV:N/AC:L/Au:N/C:P/I:N/A:N","version":"2.0"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"The HTML\\Browser plugin in SabreDAV before 1.6.9, 1.7.x before 1.7.7, and 1.8.x before 1.8.5, as used in ownCloud, when running on Windows, does not properly check path separators in the base path, which allows remote attackers to read arbitrary files via a \\ (backslash) character.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"SabreDAV Directory Traversal vulnerability","id":"CVE-2013-1939","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"owncloud:owncloud_server","products":["owncloud:owncloud_server"],"type":"path_traversal","year":"2013"},"n_packages":6,"n_references":2,"next":{"headline":"Information disclosure in n/a","id":"CVE-2013-1940"},"packages":[{"ecosystem":"Packagist","fixed":["1.6.9"],"introduced":["1.6.0"],"last_affected":[],"package":"sabre/dav","purl":null,"source":"GHSA-qg5v-jw6f-rpfj"},{"ecosystem":"Packagist","fixed":["1.6.9"],"introduced":["1.6.0"],"last_affected":[],"package":"sabre/dav","purl":"pkg:composer/sabre/dav","source":"GHSA-qg5v-jw6f-rpfj"},{"ecosystem":"Packagist","fixed":["1.7.7"],"introduced":["1.7.0"],"last_affected":[],"package":"sabre/dav","purl":null,"source":"GHSA-qg5v-jw6f-rpfj"},{"ecosystem":"Packagist","fixed":["1.7.7"],"introduced":["1.7.0"],"last_affected":[],"package":"sabre/dav","purl":"pkg:composer/sabre/dav","source":"GHSA-qg5v-jw6f-rpfj"},{"ecosystem":"Packagist","fixed":["1.8.5"],"introduced":["1.8.0"],"last_affected":[],"package":"sabre/dav","purl":null,"source":"GHSA-qg5v-jw6f-rpfj"},{"ecosystem":"Packagist","fixed":["1.8.5"],"introduced":["1.8.0"],"last_affected":[],"package":"sabre/dav","purl":"pkg:composer/sabre/dav","source":"GHSA-qg5v-jw6f-rpfj"}],"prev":{"headline":"Zimbra 2013 has XSS in aspell.php","id":"CVE-2013-1938"},"products":["n/a"],"published":"2014-03-14","related":[{"cvss_score":7.5,"headline":"XXE in SabreDAV","id":"CVE-2014-2055","kev_date_added":null,"published":"2014-06-04"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can read arbitrary files on Windows systems by exploiting improper path separator checks in the SabreDAV HTML Browser plugin.","url":"https://insights.sbomify.com/CVE-2013-1939/"}