# CVE-2013-2013: python-keystoneclient unsecure user password update

> Local attackers can read sensitive passwords from process listings when using the user-password-update command in the Python Keystone client.

- **Severity:** Low 2.1 (`AV:L/AC:L/Au:N/C:P/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Oct 2013
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2013-2013, GHSA-8q2m-pwxf-jc7g, PYSEC-2013-24

## What is CVE-2013-2013?

CVE-2013-2013 is a low-severity vulnerability in n/a, published on 1 Oct 2013. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

The user-password-update command in python-keystoneclient before 0.2.4 accepts the new password in the --password argument, which allows local users to obtain sensitive information by listing the process.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2013-2013?

3 open source packages ship an affected version, including python-keystoneclient. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `python-keystoneclient` | PyPI | All versions | 0.2.4 |
| `python-keystoneclient` | PyPI | All versions | 0.2.4 |
| `python-keystoneclient` | PyPI | All versions | 0.2.4 |

Products: Openstack Python-Keystoneclient.

## How do I fix CVE-2013-2013?

Upgrade python-keystoneclient to 0.2.4 or later.

## Is CVE-2013-2013 being exploited?

There is no known exploitation of CVE-2013-2013 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2014-0105](https://insights.sbomify.com/CVE-2014-0105/): python-keystoneclient vulnerable to context confusion in Keystone auth_token middleware (medium 6.0)
- [CVE-2013-2104](https://insights.sbomify.com/CVE-2013-2104/): python-keystoneclient missing expiration check in PKI token validation (medium 5.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2013-2013 and fix it if it is affected.

What it is: CVE-2013-2013 is a low-severity vulnerability in n/a, published on 1 Oct 2013. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2013-2013 in the wild and no public exploit code.

Affected packages and fixed versions:
- python-keystoneclient (PyPI): affected all versions; fixed in 0.2.4
- python-keystoneclient (PyPI): affected all versions; fixed in 0.2.4
- python-keystoneclient (PyPI): affected all versions; fixed in 0.2.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2013-2013/ (Markdown: https://insights.sbomify.com/CVE-2013-2013/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2013-2013
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2013-2013
- OSV: https://osv.dev/vulnerability/CVE-2013-2013

---
From sbomify Insights: https://insights.sbomify.com/CVE-2013-2013/
Summaries are generated and may contain mistakes; the official description above is the record.
