# CVE-2013-2022: jplayer Cross Site Scripting vulnerability

> Remote attackers can inject arbitrary web script or HTML via jQuery or id parameters in the jPlayer Flash component, requiring user interaction.

- **Severity:** Medium 4.3 (`AV:N/AC:M/Au:N/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 17 Aug 2013
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-3jcq-cwr7-6332, UBUNTU-CVE-2013-2022

## What is CVE-2013-2022?

CVE-2013-2022 is a medium-severity cross-site scripting vulnerability in n/a, published on 17 Aug 2013. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Multiple cross-site scripting (XSS) vulnerabilities in actionscript/Jplayer.as in the Flash SWF component (jplayer.swf) in jPlayer before 2.2.23 allow remote attackers to inject arbitrary web script or HTML via the (1) jQuery or (2) id parameters, a different vulnerability than CVE-2013-1942 and CVE-2013-2023, as demonstrated by using the alert function in the jQuery parameter.  NOTE: these are the same parameters as CVE-2013-1942, but the fix for CVE-2013-1942 uses a blacklist for the jQuery parameter.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2013-2022?

2 open source packages ship an affected version, including jplayer. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `jplayer` | npm | All versions | 2.3.0 |
| `jplayer` | npm | All versions | 2.3.0 |

Products: Happyworm Jplayer.

## How do I fix CVE-2013-2022?

Upgrade jplayer to 2.3.0 or later.

## Is CVE-2013-2022 being exploited?

There is no known exploitation of CVE-2013-2022 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2013-1942](https://insights.sbomify.com/CVE-2013-1942/): Cross-site scripting in n/a (medium 4.3)
- [CVE-2013-2023](https://insights.sbomify.com/CVE-2013-2023/): Cross-site scripting in n/a (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2013-2022 and fix it if it is affected.

What it is: CVE-2013-2022 is a medium-severity cross-site scripting vulnerability in n/a, published on 17 Aug 2013. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2013-2022 in the wild and no public exploit code.

Affected packages and fixed versions:
- jplayer (npm): affected all versions; fixed in 2.3.0
- jplayer (npm): affected all versions; fixed in 2.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2013-2022/ (Markdown: https://insights.sbomify.com/CVE-2013-2022/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2013-2022
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2013-2022
- OSV: https://osv.dev/vulnerability/CVE-2013-2022

---
From sbomify Insights: https://insights.sbomify.com/CVE-2013-2022/
Summaries are generated and may contain mistakes; the official description above is the record.
