# CVE-2013-2027: Jython Improper Access Restrictions vulnerability

> Local attackers can bypass access restrictions on Jython class cache files by exploiting insecure umask handling during file creation.

- **Severity:** Medium 4.6 (`AV:L/AC:L/Au:N/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Feb 2015
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2013-2027, GHSA-9347-9w64-q5wp, MGASA-2015-0096, UBUNTU-CVE-2013-2027, openSUSE-SU-2024:10443-1

## What is CVE-2013-2027?

CVE-2013-2027 is a medium-severity vulnerability in Opensuse Opensuse, published on 13 Feb 2015. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Jython 2.2.1 uses the current umask to set the privileges of the class cache files, which allows local users to bypass intended access restrictions via unspecified vectors.

Weakness: CWE-264

## Which versions are affected by CVE-2013-2027?

2 open source packages ship an affected version, including org.python:jython-standalone. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.python:jython-standalone` | Maven | All versions | 2.7.2b3 |
| `org.python:jython-standalone` | Maven | All versions | 2.7.2b3 |

Products: Jython Project Jython, Opensuse Opensuse.

## How do I fix CVE-2013-2027?

Upgrade org.python:jython-standalone to 2.7.2b3 or later.

## Is CVE-2013-2027 being exploited?

There is no known exploitation of CVE-2013-2027 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2013-2027 and fix it if it is affected.

What it is: CVE-2013-2027 is a medium-severity vulnerability in Opensuse Opensuse, published on 13 Feb 2015. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2013-2027 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.python:jython-standalone (Maven): affected all versions; fixed in 2.7.2b3
- org.python:jython-standalone (Maven): affected all versions; fixed in 2.7.2b3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2013-2027/ (Markdown: https://insights.sbomify.com/CVE-2013-2027/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2013-2027
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2013-2027
- OSV: https://osv.dev/vulnerability/CVE-2013-2027

---
From sbomify Insights: https://insights.sbomify.com/CVE-2013-2027/
Summaries are generated and may contain mistakes; the official description above is the record.
