CVE-2013-2034 Jenkins Cross-Site Request Forgery vulnerabilities

Medium 6.8 Published Updated

Remote attackers can hijack administrator sessions to execute arbitrary code or deploy binaries via CSRF, requiring admin interaction.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2013-2034?

CVE-2013-2034 is a medium-severity vulnerability in n/a, published on 14 May 2014. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

Official description

Multiple cross-site request forgery (CSRF) vulnerabilities in Jenkins before 1.514, LTS before 1.509.1, and Enterprise 1.466.x before 1.466.14.1 and 1.480.x before 1.480.4.1 allow remote attackers to hijack the authentication of administrators for requests that (1) execute arbitrary code or (2) initiate deployment of binaries to a Maven repository via unspecified vectors.

Weakness: CWE-352

Which versions are affected by CVE-2013-2034?

4 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core. It affects 1 product.

PackageAffectedFixed in
org.jenkins-ci.main:jenkins-core MavenAll versions1.509.1
org.jenkins-ci.main:jenkins-core MavenAll versions1.509.1
org.jenkins-ci.main:jenkins-core MavenFrom 1.5131.514
org.jenkins-ci.main:jenkins-core MavenFrom 1.5131.514

Products include Cloudbees Jenkins.

How do I fix CVE-2013-2034?

Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 1.509.1 or 1.514.

Is CVE-2013-2034 being exploited?

There is no known exploitation of CVE-2013-2034 in the wild and no public exploit code.

Sources

Also known as GHSA-fg4r-f9j2-36mw.

Is CVE-2013-2034 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free