{"answers":{"affected":"4 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core. It affects 1 product.","exploited":"There is no known exploitation of CVE-2013-2034 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 1.509.1 or 1.514.","what":"CVE-2013-2034 is a medium-severity vulnerability in n/a, published on 14 May 2014. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2013-2034 and fix it if it is affected.\n\nWhat it is: CVE-2013-2034 is a medium-severity vulnerability in n/a, published on 14 May 2014. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2013-2034 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.main:jenkins-core (Maven): affected all versions; fixed in 1.509.1\n- org.jenkins-ci.main:jenkins-core (Maven): affected all versions; fixed in 1.509.1\n- org.jenkins-ci.main:jenkins-core (Maven): affected from 1.513; fixed in 1.514\n- org.jenkins-ci.main:jenkins-core (Maven): affected from 1.513; fixed in 1.514\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2013-2034/ (Markdown: https://insights.sbomify.com/CVE-2013-2034/index.md)","id":"CVE-2013-2034","markdown":"https://insights.sbomify.com/CVE-2013-2034/index.md","name":"CVE-2013-2034","record":{"aliases":["GHSA-fg4r-f9j2-36mw"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution","privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins CI server","requires_auth":"high_privilege","summary":"Remote attackers can hijack administrator sessions to execute arbitrary code or deploy binaries via CSRF, requiring admin interaction.","user_interaction":"required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"jenkins","vendor":"cloudbees"}],"cvss":{"score":6.8,"severity":"medium","source":"nvd","vector":"AV:N/AC:M/Au:N/C:P/I:P/A:P","version":"2.0"},"cwes":[{"id":"CWE-352","name":"Cross-Site Request Forgery"}],"description":"Multiple cross-site request forgery (CSRF) vulnerabilities in Jenkins before 1.514, LTS before 1.509.1, and Enterprise 1.466.x before 1.466.14.1 and 1.480.x before 1.480.4.1 allow remote attackers to hijack the authentication of administrators for requests that (1) execute arbitrary code or (2) initiate deployment of binaries to a Maven repository via unspecified vectors.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Jenkins Cross-Site Request Forgery vulnerabilities","id":"CVE-2013-2034","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"csrf","year":"2013"},"n_packages":4,"n_references":2,"next":{"headline":"Improper Control of Generation of Code in HawtJNI","id":"CVE-2013-2035"},"packages":[{"ecosystem":"Maven","fixed":["1.509.1"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.main:jenkins-core","purl":null,"source":"GHSA-fg4r-f9j2-36mw"},{"ecosystem":"Maven","fixed":["1.509.1"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.main:jenkins-core","purl":"pkg:maven/org.jenkins-ci.main/jenkins-core","source":"GHSA-fg4r-f9j2-36mw"},{"ecosystem":"Maven","fixed":["1.514"],"introduced":["1.513"],"last_affected":[],"package":"org.jenkins-ci.main:jenkins-core","purl":null,"source":"GHSA-fg4r-f9j2-36mw"},{"ecosystem":"Maven","fixed":["1.514"],"introduced":["1.513"],"last_affected":[],"package":"org.jenkins-ci.main:jenkins-core","purl":"pkg:maven/org.jenkins-ci.main/jenkins-core","source":"GHSA-fg4r-f9j2-36mw"}],"prev":{"headline":"Jenkins vulnerable to Cross-site Scripting","id":"CVE-2013-2033"},"products":["n/a"],"published":"2014-05-14","related":[{"cvss_score":7.5,"headline":"Hash collision attack vulnerability in Jenkins","id":"CVE-2012-0785","kev_date_added":null,"published":"2020-02-24"},{"cvss_score":5.8,"headline":"Jenkins affected by Open Redirect Vulnerability","id":"CVE-2012-6073","kev_date_added":null,"published":"2013-02-24"},{"cvss_score":4.3,"headline":"Jenkins allows HTTP Injection and Response Splitting","id":"CVE-2012-6072","kev_date_added":null,"published":"2013-02-24"},{"cvss_score":4.3,"headline":"Jenkins allows Cross-Site Scripting (XSS)","id":"CVE-2012-0324","kev_date_added":null,"published":"2012-03-09"},{"cvss_score":4.3,"headline":"Jenkins allows Cross-Site Scripting (XSS)","id":"CVE-2012-0325","kev_date_added":null,"published":"2012-03-09"},{"cvss_score":3.5,"headline":"Jenkins allows Cross-Site Scripting (XSS)","id":"CVE-2012-6074","kev_date_added":null,"published":"2013-02-24"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can hijack administrator sessions to execute arbitrary code or deploy binaries via CSRF, requiring admin interaction.","url":"https://insights.sbomify.com/CVE-2013-2034/"}