CVE-2013-2080 Moodle is vulnerable to Sensitive Information Disclosure
Authenticated students can view hidden grades in Moodle Gradebook Overview, leading to unauthorized disclosure of sensitive academic information.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2013-2080?
CVE-2013-2080 is a medium-severity vulnerability in Moodle Moodle, published on 25 May 2013. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
The core_grade component in Moodle through 2.2.10, 2.3.x before 2.3.7, and 2.4.x before 2.4.4 does not properly consider the existence of hidden grades, which allows remote authenticated users to obtain sensitive information by leveraging the student role and reading the Gradebook Overview report.
Weakness: CWE-264
Which versions are affected by CVE-2013-2080?
4 open source packages ship an affected version, including moodle/moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | All versions | 2.3.7 |
moodle/moodle Packagist | All versions | 2.3.7 |
moodle/moodle Packagist | From 2.4.0 | 2.4.4 |
moodle/moodle Packagist | From 2.4.0 | 2.4.4 |
Products include Moodle Moodle.
How do I fix CVE-2013-2080?
Upgrade moodle/moodle to a fixed version for your release line: 2.3.7 or 2.4.4.
Is CVE-2013-2080 being exploited?
There is no known exploitation of CVE-2013-2080 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as GHSA-wmmc-qjq2-vvm2, UBUNTU-CVE-2013-2080.