CVE-2013-2082 Moodle does not enforce capability requirements for reading blog comments

Medium 5.0 Published Updated

Remote attackers can read blog comments without proper authorization, exposing sensitive information in Moodle installations.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2013-2082?

CVE-2013-2082 is a medium-severity missing authorization vulnerability in Moodle Moodle, published on 25 May 2013. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Moodle through 2.1.10, 2.2.x before 2.2.10, 2.3.x before 2.3.7, and 2.4.x before 2.4.4 does not enforce capability requirements for reading blog comments, which allows remote attackers to obtain sensitive information via a crafted request.

Weakness: CWE-264

Which versions are affected by CVE-2013-2082?

6 open source packages ship an affected version, including moodle/moodle. It affects 1 product.

PackageAffectedFixed in
moodle/moodle PackagistAll versions2.2.10
moodle/moodle PackagistAll versions2.2.10
moodle/moodle PackagistFrom 2.3.02.3.7
moodle/moodle PackagistFrom 2.3.02.3.7
moodle/moodle PackagistFrom 2.4.02.4.4
moodle/moodle PackagistFrom 2.4.02.4.4

Products include Moodle Moodle.

How do I fix CVE-2013-2082?

Upgrade moodle/moodle to a fixed version for your release line: 2.2.10, 2.3.7 or 2.4.4.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2013-2082 being exploited?

There is no known exploitation of CVE-2013-2082 in the wild and no public exploit code.

All Moodle Moodle vulnerabilities

Sources

Also known as GHSA-wp3g-pr4h-q6vv, UBUNTU-CVE-2013-2082.

Is CVE-2013-2082 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free