CVE-2013-2083 Moodle is vulnerable to Improper Input Validation in MoodleQuickForm class

Medium 5.0 Published Updated

Remote attackers can bypass form-data filtering in Moodle by exploiting improper handling of array-element syntax in the MoodleQuickForm class.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2013-2083?

CVE-2013-2083 is a medium-severity vulnerability in Moodle Moodle, published on 25 May 2013. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

The MoodleQuickForm class in lib/formslib.php in Moodle through 2.1.10, 2.2.x before 2.2.10, 2.3.x before 2.3.7, and 2.4.x before 2.4.4 does not properly handle a certain array-element syntax, which allows remote attackers to bypass intended form-data filtering via a crafted request.

Weakness: CWE-20

Which versions are affected by CVE-2013-2083?

6 open source packages ship an affected version, including moodle/moodle. It affects 1 product.

PackageAffectedFixed in
moodle/moodle PackagistAll versions2.2.10
moodle/moodle PackagistAll versions2.2.10
moodle/moodle PackagistFrom 2.3.02.3.7
moodle/moodle PackagistFrom 2.3.02.3.7
moodle/moodle PackagistFrom 2.4.02.4.4
moodle/moodle PackagistFrom 2.4.02.4.4

Products include Moodle Moodle.

How do I fix CVE-2013-2083?

Upgrade moodle/moodle to a fixed version for your release line: 2.2.10, 2.3.7 or 2.4.4.

Is CVE-2013-2083 being exploited?

There is no known exploitation of CVE-2013-2083 in the wild and no public exploit code.

All Moodle Moodle vulnerabilities

Sources

Also known as GHSA-m63h-q4x3-6hwj, UBUNTU-CVE-2013-2083.

Is CVE-2013-2083 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free