{"answers":{"affected":"2 open source packages ship an affected version, including portage. It affects 1 product.","exploited":"There is no known exploitation of CVE-2013-2100 in the wild and no public exploit code.","fix":"Upgrade portage to 2.1.12.2 or later.","what":"CVE-2013-2100 is a critical vulnerability in n/a, published on 29 Sep 2014. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2013-2100 and fix it if it is affected.\n\nWhat it is: CVE-2013-2100 is a critical vulnerability in n/a, published on 29 Sep 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2013-2100 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- portage (PyPI): affected all versions; fixed in 2.1.12.2\n- portage (PyPI): affected all versions; fixed in 2.1.12.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2013-2100/ (Markdown: https://insights.sbomify.com/CVE-2013-2100/index.md)","id":"CVE-2013-2100","markdown":"https://insights.sbomify.com/CVE-2013-2100/index.md","name":"CVE-2013-2100","record":{"aliases":["GHSA-8823-xphr-qw9v"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_modify","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Gentoo Portage library","requires_auth":"none","summary":"Man-in-the-middle attackers can spoof servers and modify binary package lists because the library fails to verify SSL certificates.","user_interaction":"not_required","vuln_class":"weak_cryptography"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"portage","vendor":"gentoo"}],"cvss":{"score":9.3,"severity":"critical","source":"nvd","vector":"AV:N/AC:M/Au:N/C:C/I:C/A:C","version":"2.0"},"cwes":[{"id":"CWE-310","name":null}],"description":"The urlopen function in pym/portage/util/_urlopen.py in Gentoo Portage 2.1.12, when using HTTPS, does not verify X.509 certificates from SSL servers, which allows man-in-the-middle attackers to spoof servers and modify binary package lists via a crafted certificate.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Gentoo Portage does not verify X.509 certificates from SSL servers","id":"CVE-2013-2100","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"weak_cryptography","year":"2013"},"n_packages":2,"n_references":6,"next":{"headline":"Cross-site scripting in Katello","id":"CVE-2013-2101"},"packages":[{"ecosystem":"PyPI","fixed":["2.1.12.2"],"introduced":["0"],"last_affected":[],"package":"portage","purl":null,"source":"GHSA-8823-xphr-qw9v"},{"ecosystem":"PyPI","fixed":["2.1.12.2"],"introduced":["0"],"last_affected":[],"package":"portage","purl":"pkg:pypi/portage","source":"GHSA-8823-xphr-qw9v"}],"prev":{"headline":"Denial of service in n/a","id":"CVE-2013-2099"},"products":["n/a"],"published":"2014-09-29","related":[{"cvss_score":9.8,"headline":"Gentoo Portage missing PGP validation of executed code","id":"CVE-2016-20021","kev_date_added":null,"published":"2024-01-12"},{"cvss_score":7.1,"headline":"Privilege escalation in n/a","id":"CVE-2004-2778","kev_date_added":null,"published":"2017-06-27"},{"cvss_score":6.9,"headline":"Path traversal in n/a","id":"CVE-2008-4394","kev_date_added":null,"published":"2008-10-10"},{"cvss_score":5.5,"headline":"Race condition in n/a","id":"CVE-2019-20384","kev_date_added":null,"published":"2020-01-20"},{"cvss_score":2.1,"headline":"Information disclosure in n/a","id":"CVE-2007-6249","kev_date_added":null,"published":"2007-12-15"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Man-in-the-middle attackers can spoof servers and modify binary package lists because the library fails to verify SSL certificates.","url":"https://insights.sbomify.com/CVE-2013-2100/"}