{"answers":{"affected":"It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2013-2107 exists.","fix":"No fix has been published for CVE-2013-2107 yet. Limit exposure of the affected software until one is available.","what":"CVE-2013-2107 is a medium-severity vulnerability in n/a, published on 23 May 2014. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2013-2107 and fix it if it is affected.\n\nWhat it is: CVE-2013-2107 is a medium-severity vulnerability in n/a, published on 23 May 2014. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2013-2107 exists.\n\nAffected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2013-2107/ (Markdown: https://insights.sbomify.com/CVE-2013-2107/index.md)","id":"CVE-2013-2107","markdown":"https://insights.sbomify.com/CVE-2013-2107/index.md","name":"CVE-2013-2107","record":{"aliases":["GHSA-wc3q-ccmv-3p9w"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["privilege_escalation","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress plugin","requires_auth":"high_privilege","summary":"A CSRF vulnerability in the Mail On Update WordPress plugin allows attackers to hijack administrator sessions to modify email recipient settings.","user_interaction":"required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"mail_on_update","vendor":"mail_on_update_project"}],"cvss":{"score":6.8,"severity":"medium","source":"nvd","vector":"AV:N/AC:M/Au:N/C:P/I:P/A:P","version":"2.0"},"cwes":[{"id":"CWE-352","name":"Cross-Site Request Forgery"}],"description":"Cross-site request forgery (CSRF) vulnerability in the Mail On Update plugin before 5.2.0 for WordPress allows remote attackers to hijack the authentication of administrators for requests that change the \"List of alternative recipients\" via the mailonupdate_mailto parameter in the mail-on-update page to wp-admin/options-general.php.  NOTE: a third party claims that 5.2.1 and 5.2.2 are also vulnerable, but the issue might require a separate CVE identifier since this might reflect an incomplete fix.","ecosystems":[],"exploits":{"exploitdb":1,"first_seen":"2013-05-16","github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[{"date":"2013-05-16","kind":"exploitdb","ref":"38517","stars":null,"title":"WordPress Plugin Mail On Update - Cross-Site Request Forgery"}],"tier":"weaponised"},"has_fix":null,"headline":"Cross-site request forgery in n/a","id":"CVE-2013-2107","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"csrf","year":"2013"},"n_packages":0,"n_references":4,"next":{"headline":"Cross-site request forgery in WP Cleanfix Plugin","id":"CVE-2013-2108"},"packages":[],"prev":{"headline":"Information disclosure in webauth","id":"CVE-2013-2106"},"products":["n/a"],"published":"2014-05-23","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"GPL-2.0-or-later","name":"Exploit-DB"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"A CSRF vulnerability in the Mail On Update WordPress plugin allows attackers to hijack administrator sessions to modify email recipient settings.","url":"https://insights.sbomify.com/CVE-2013-2107/"}