CVE-2013-2119 Phusion Passenger Denial of Service
Local attackers can exploit a race condition in Phusion Passenger to gain privileges or cause denial of service by pre-creating predictable temporary files.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Local or same network only
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2013-2119?
CVE-2013-2119 is a medium-severity vulnerability in Redhat Openshift, published on 2 Jan 2014. It can only be exploited from the same machine or local network, with no action from the victim.
Official description
Phusion Passenger gem before 3.0.21 and 4.0.x before 4.0.5 for Ruby allows local users to cause a denial of service (prevent application start) or gain privileges by pre-creating a temporary "config" file in a directory with a predictable name in /tmp/ before it is used by the gem.
Weakness: CWE-264
Which versions are affected by CVE-2013-2119?
4 open source packages ship an affected version, including passenger. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
passenger RubyGems | All versions | 3.0.21 |
passenger RubyGems | All versions | 3.0.21 |
passenger RubyGems | From 4.0.1 | 4.0.5 |
passenger RubyGems | From 4.0.1 | 4.0.5 |
Products include Phusion Passenger, Redhat Openshift.
How do I fix CVE-2013-2119?
Upgrade passenger to a fixed version for your release line: 3.0.21 or 4.0.5.
Is CVE-2013-2119 being exploited?
There is no known exploitation of CVE-2013-2119 in the wild and no public exploit code.
Other vulnerabilities in Redhat Openshift
- CVE-2018-12026 Phusion Passenger SpawningKit Contains Arbitrary Read/Write Vulnerability
- CVE-2018-12027 Insecure Permissions in Phusion Passenger
- CVE-2018-12028 Incorrect Access Control in Phusion Passenger
- CVE-2016-10345 Phusion Passenger uses a known /tmp filename
- CVE-2012-6135 RubyGems passenger gem allows remote attackers to delete files
Sources
Also known as GHSA-9qj7-jvg4-qr2x, MGASA-2013-0205.