# CVE-2013-2167: Insufficient Verification of Data Authenticity in python-keystoneclient

> Attackers can bypass memcache signing in python-keystoneclient, potentially compromising authentication integrity in OpenStack environments.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Dec 2019
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2013-2167, GHSA-9vg3-cf92-h2h7, PYSEC-2019-161

## What is CVE-2013-2167?

CVE-2013-2167 is a critical vulnerability in Debian Debian Linux, published on 10 Dec 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

python-keystoneclient version 0.2.3 to 0.2.5 has middleware memcache signing bypass

Weakness: CWE-345 (Insufficient Verification of Data Authenticity)

## Which versions are affected by CVE-2013-2167?

3 open source packages ship an affected version, including python-keystoneclient. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `python-keystoneclient` | PyPI | From 0.2.3 | 0.3.0 |
| `python-keystoneclient` | PyPI | From 0.2.3 | 0.3.0 |
| `python-keystoneclient` | PyPI | From 0.2.3 | 0.3.0 |

Products: Debian Debian Linux, Openstack Python-Keystoneclient, Redhat Openstack.

## How do I fix CVE-2013-2167?

Upgrade python-keystoneclient to 0.3.0 or later.

## Is CVE-2013-2167 being exploited?

There is no known exploitation of CVE-2013-2167 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2013-2167 and fix it if it is affected.

What it is: CVE-2013-2167 is a critical vulnerability in Debian Debian Linux, published on 10 Dec 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2013-2167 in the wild and no public exploit code.

Affected packages and fixed versions:
- python-keystoneclient (PyPI): affected from 0.2.3; fixed in 0.3.0
- python-keystoneclient (PyPI): affected from 0.2.3; fixed in 0.3.0
- python-keystoneclient (PyPI): affected from 0.2.3; fixed in 0.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2013-2167/ (Markdown: https://insights.sbomify.com/CVE-2013-2167/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2013-2167
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2013-2167
- OSV: https://osv.dev/vulnerability/CVE-2013-2167

---
From sbomify Insights: https://insights.sbomify.com/CVE-2013-2167/
Summaries are generated and may contain mistakes; the official description above is the record.
