# CVE-2013-2172: Inefficient Algorithmic Complexity in Apache Santuario XML Security

> Attackers can spoof XML signatures by specifying weak canonicalization algorithms, bypassing security checks in Apache Santuario XML Security for Java.

- **Severity:** Medium 4.3 (`AV:N/AC:M/Au:N/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Aug 2013
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2013-2172, DLA-85-1, DSA-3065-1, GHSA-r237-w2w6-jq3p, MGASA-2014-0002, RHSA-2013:1217, RHSA-2013:1219

## What is CVE-2013-2172?

CVE-2013-2172 is a medium-severity vulnerability in n/a, published on 20 Aug 2013. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

jcp/xml/dsig/internal/dom/DOMCanonicalizationMethod.java in Apache Santuario XML Security for Java 1.4.x before 1.4.8 and 1.5.x before 1.5.5 allows context-dependent attackers to spoof an XML Signature by using the CanonicalizationMethod parameter to specify an arbitrary weak "canonicalization algorithm to apply to the SignedInfo part of the Signature."

Weakness: CWE-310

## Which versions are affected by CVE-2013-2172?

4 open source packages ship an affected version, including org.apache.santuario:xmlsec. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.santuario:xmlsec` | Maven | From 1.4.0 | 1.4.8 |
| `org.apache.santuario:xmlsec` | Maven | From 1.4.0 | 1.4.8 |
| `org.apache.santuario:xmlsec` | Maven | From 1.5.0 | 1.5.5 |
| `org.apache.santuario:xmlsec` | Maven | From 1.5.0 | 1.5.5 |
| `xml-security` | Red Hat:jboss_enterprise_application_platform:5::el4 | All versions | 0:1.5.1-3_patch01.ep5.el4 |
| `xml-security` | Red Hat:jboss_enterprise_application_platform:5::el5 | All versions | 0:1.5.1-3_patch01.ep5.el5 |
| `xml-security` | Red Hat:jboss_enterprise_application_platform:5::el6 | All versions | 0:1.5.1-3_patch01.ep5.el6 |
| `xml-security` | Red Hat:jboss_enterprise_web_platform:5::el5 | All versions | 0:1.5.1-3_patch01.ep5.el5 |
| `xml-security` | Red Hat:jboss_enterprise_web_platform:5::el6 | All versions | 0:1.5.1-3_patch01.ep5.el6 |

Products: Apache Santuario Xml Security for Java.

## How do I fix CVE-2013-2172?

Upgrade org.apache.santuario:xmlsec to a fixed version for your release line: 1.4.8 or 1.5.5.

## Is CVE-2013-2172 being exploited?

There is no known exploitation of CVE-2013-2172 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2023-44483](https://insights.sbomify.com/CVE-2023-44483/): Apache Santuario: Private Key disclosure in debug-log output (medium 6.5)
- [CVE-2019-12400](https://insights.sbomify.com/CVE-2019-12400/): Improper input validation in Apache Santuario XML Security for Java (medium 5.5)
- [CVE-2014-8152](https://insights.sbomify.com/CVE-2014-8152/): Improper Input Validation in Apache Santuario XML Security (medium 5.0)
- [CVE-2013-4517](https://insights.sbomify.com/CVE-2013-4517/): Improper Input Validation in Apache Santuario XML Security (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2013-2172 and fix it if it is affected.

What it is: CVE-2013-2172 is a medium-severity vulnerability in n/a, published on 20 Aug 2013. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2013-2172 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.santuario:xmlsec (Maven): affected from 1.4.0; fixed in 1.4.8
- org.apache.santuario:xmlsec (Maven): affected from 1.4.0; fixed in 1.4.8
- org.apache.santuario:xmlsec (Maven): affected from 1.5.0; fixed in 1.5.5
- org.apache.santuario:xmlsec (Maven): affected from 1.5.0; fixed in 1.5.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2013-2172/ (Markdown: https://insights.sbomify.com/CVE-2013-2172/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2013-2172
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2013-2172
- OSV: https://osv.dev/vulnerability/CVE-2013-2172

---
From sbomify Insights: https://insights.sbomify.com/CVE-2013-2172/
Summaries are generated and may contain mistakes; the official description above is the record.
