{"answers":{"affected":"3 open source packages ship an affected version, including python-bugzilla. It affects 3 products.","exploited":"There is no known exploitation of CVE-2013-2191 in the wild and no public exploit code.","fix":"Upgrade python-bugzilla to 0.9.0 or later.","what":"CVE-2013-2191 is a medium-severity vulnerability in Fedoraproject Fedora, published on 8 Feb 2014. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2013-2191 and fix it if it is affected.\n\nWhat it is: CVE-2013-2191 is a medium-severity vulnerability in Fedoraproject Fedora, published on 8 Feb 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2013-2191 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- python-bugzilla (PyPI): affected all versions; fixed in 0.9.0\n- python-bugzilla (PyPI): affected all versions; fixed in 0.9.0\n- python-bugzilla (PyPI): affected all versions; fixed in 0.9.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2013-2191/ (Markdown: https://insights.sbomify.com/CVE-2013-2191/index.md)","id":"CVE-2013-2191","markdown":"https://insights.sbomify.com/CVE-2013-2191/index.md","name":"CVE-2013-2191","record":{"aliases":["GHSA-2q4h-27m7-rj67","PYSEC-2014-88","openSUSE-SU-2024:10058-1","openSUSE-SU-2024:11221-1","openSUSE-SU-2024:14135-1","openSUSE-SU-2026:12002-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Python Bugzilla library","requires_auth":"none","summary":"Man-in-the-middle attackers can spoof Bugzilla servers because the library fails to validate X.509 certificates.","user_interaction":"not_required","vuln_class":"weak_cryptography"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"fedora","vendor":"fedoraproject"},{"product":"opensuse","vendor":"opensuse"},{"product":"python-bugzilla","vendor":"python_bugzilla_project"}],"cvss":{"score":4.3,"severity":"medium","source":"nvd","vector":"AV:N/AC:M/Au:N/C:N/I:P/A:N","version":"2.0"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"python-bugzilla before 0.9.0 does not validate X.509 certificates, which allows man-in-the-middle attackers to spoof Bugzilla servers via a crafted certificate.","ecosystems":["PyPI","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"python-bugzilla has improper validation of X.509 certificates","id":"CVE-2013-2191","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":"fedoraproject:fedora","products":["fedoraproject:fedora","opensuse:opensuse"],"type":"weak_cryptography","year":"2013"},"n_packages":6,"n_references":6,"next":{"headline":"Improper Authentication in Apache Hadoop","id":"CVE-2013-2192"},"packages":[{"ecosystem":"PyPI","fixed":["0.9.0"],"introduced":["0"],"last_affected":[],"package":"python-bugzilla","purl":null,"source":"GHSA-2q4h-27m7-rj67"},{"ecosystem":"PyPI","fixed":["0.9.0"],"introduced":["0"],"last_affected":[],"package":"python-bugzilla","purl":"pkg:pypi/python-bugzilla","source":"GHSA-2q4h-27m7-rj67"},{"ecosystem":"PyPI","fixed":["0.9.0"],"introduced":["0"],"last_affected":[],"package":"python-bugzilla","purl":"pkg:pypi/python-bugzilla","source":"PYSEC-2014-88"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["1.2.2-1.1"],"introduced":["0"],"last_affected":[],"package":"python-bugzilla","purl":"pkg:rpm/opensuse/python-bugzilla\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:10058-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["3.2.0-2.3"],"introduced":["0"],"last_affected":[],"package":"python-bugzilla","purl":"pkg:rpm/opensuse/python-bugzilla\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:14135-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["3.3.0-1.4"],"introduced":["0"],"last_affected":[],"package":"python-bugzilla","purl":"pkg:rpm/opensuse/python-bugzilla\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2026:12002-1"}],"prev":{"headline":"Denial of service in n/a","id":"CVE-2013-2190"},"products":["n/a"],"published":"2014-02-08","related":[{"cvss_score":9.8,"headline":"PHP-CGI OS Command Injection","id":"CVE-2024-4577","kev_date_added":"2024-06-12","published":"2024-06-09"},{"cvss_score":9.8,"headline":"Grafana Authentication Bypass","id":"CVE-2021-39226","kev_date_added":"2022-08-25","published":"2021-10-05"},{"cvss_score":9.8,"headline":"VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow","id":"CVE-2019-5544","kev_date_added":"2021-11-03","published":"2019-12-06"},{"cvss_score":9.6,"headline":"Google Chromium V8 Type Confusion","id":"CVE-2024-4947","kev_date_added":"2024-05-20","published":"2024-05-15"},{"cvss_score":9.6,"headline":"Google Chromium Visuals Use-After-Free","id":"CVE-2024-4671","kev_date_added":"2024-05-13","published":"2024-05-09"},{"cvss_score":9.6,"headline":"Google Chromium Mojo Insufficient Data Validation","id":"CVE-2022-3075","kev_date_added":"2022-09-08","published":"2022-09-26"},{"cvss_score":9.6,"headline":"Google Chromium Indexed DB API Use-After-Free","id":"CVE-2021-30633","kev_date_added":"2021-11-03","published":"2021-10-08"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Man-in-the-middle attackers can spoof Bugzilla servers because the library fails to validate X.509 certificates.","url":"https://insights.sbomify.com/CVE-2013-2191/"}