# CVE-2013-2191: python-bugzilla has improper validation of X.509 certificates

> Man-in-the-middle attackers can spoof Bugzilla servers because the library fails to validate X.509 certificates.

- **Severity:** Medium 4.3 (`AV:N/AC:M/Au:N/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Feb 2014
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-2q4h-27m7-rj67, PYSEC-2014-88, openSUSE-SU-2024:10058-1, openSUSE-SU-2024:11221-1, openSUSE-SU-2024:14135-1, openSUSE-SU-2026:12002-1

## What is CVE-2013-2191?

CVE-2013-2191 is a medium-severity vulnerability in Fedoraproject Fedora, published on 8 Feb 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

python-bugzilla before 0.9.0 does not validate X.509 certificates, which allows man-in-the-middle attackers to spoof Bugzilla servers via a crafted certificate.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2013-2191?

3 open source packages ship an affected version, including python-bugzilla. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `python-bugzilla` | PyPI | All versions | 0.9.0 |
| `python-bugzilla` | PyPI | All versions | 0.9.0 |
| `python-bugzilla` | PyPI | All versions | 0.9.0 |
| `python-bugzilla` | openSUSE:Tumbleweed | All versions | 1.2.2-1.1 |
| `python-bugzilla` | openSUSE:Tumbleweed | All versions | 3.2.0-2.3 |
| `python-bugzilla` | openSUSE:Tumbleweed | All versions | 3.3.0-1.4 |

Products: Fedoraproject Fedora, Opensuse Opensuse, Python Bugzilla Project Python-Bugzilla.

## How do I fix CVE-2013-2191?

Upgrade python-bugzilla to 0.9.0 or later.

## Is CVE-2013-2191 being exploited?

There is no known exploitation of CVE-2013-2191 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2013-2191 and fix it if it is affected.

What it is: CVE-2013-2191 is a medium-severity vulnerability in Fedoraproject Fedora, published on 8 Feb 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2013-2191 in the wild and no public exploit code.

Affected packages and fixed versions:
- python-bugzilla (PyPI): affected all versions; fixed in 0.9.0
- python-bugzilla (PyPI): affected all versions; fixed in 0.9.0
- python-bugzilla (PyPI): affected all versions; fixed in 0.9.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2013-2191/ (Markdown: https://insights.sbomify.com/CVE-2013-2191/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2013-2191
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2013-2191
- OSV: https://osv.dev/vulnerability/CVE-2013-2191

---
From sbomify Insights: https://insights.sbomify.com/CVE-2013-2191/
Summaries are generated and may contain mistakes; the official description above is the record.
