CVE-2013-2192 Improper Authentication in Apache Hadoop

Low 3.2 Published Updated

Man-in-the-middle attackers can bypass Kerberos authentication in Apache Hadoop RPC to access sensitive information when security features are enabled.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2013-2192?

CVE-2013-2192 is a low-severity vulnerability in n/a, published on 24 Jan 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

The RPC protocol implementation in Apache Hadoop 2.x before 2.0.6-alpha, 0.23.x before 0.23.9, and 1.x before 1.2.1, when the Kerberos security features are enabled, allows man-in-the-middle attackers to disable bidirectional authentication and obtain sensitive information by forcing a downgrade to simple authentication.

Weakness: CWE-287

Which versions are affected by CVE-2013-2192?

4 open source packages ship an affected version, including org.apache.hadoop:hadoop-common. It affects 1 product.

PackageAffectedFixed in
org.apache.hadoop:hadoop-common MavenFrom 0.23.00.23.9
org.apache.hadoop:hadoop-common MavenFrom 0.23.00.23.9
org.apache.hadoop:hadoop-common MavenFrom 2.0.02.0.6-alpha
org.apache.hadoop:hadoop-common MavenFrom 2.0.02.0.6-alpha

Products include Apache Hadoop.

How do I fix CVE-2013-2192?

Upgrade org.apache.hadoop:hadoop-common to a fixed version for your release line: 0.23.9 or 2.0.6-alpha.

Is CVE-2013-2192 being exploited?

There is no known exploitation of CVE-2013-2192 in the wild and no public exploit code.

Sources

Also known as GHSA-pxv5-5vmp-3jj4.

Is CVE-2013-2192 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free