CVE-2013-2209 Review Board Cross-site scripting (XSS) vulnerability in the reviews dropdown
Remote attackers can inject arbitrary web script or HTML via the full name field in the auto-complete widget, potentially compromising user sessions.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2013-2209?
CVE-2013-2209 is a medium-severity cross-site scripting vulnerability in n/a, published on 31 Jul 2013. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Cross-site scripting (XSS) vulnerability in the auto-complete widget in htdocs/media/rb/js/reviews.js in Review Board 1.6.x before 1.6.17 and 1.7.x before 1.7.10 allows remote attackers to inject arbitrary web script or HTML via a full name.
Weakness: CWE-79
Which versions are affected by CVE-2013-2209?
5 open source packages ship an affected version, including reviewboard. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
reviewboard PyPI | From 1.6 | 1.6.17, 1.7.10 |
reviewboard PyPI | From 1.6 | 1.6.17 |
reviewboard PyPI | From 1.6 | 1.6.17 |
reviewboard PyPI | From 1.7 | 1.7.10 |
reviewboard PyPI | From 1.7 | 1.7.10 |
Products include Reviewboard Review Board.
How do I fix CVE-2013-2209?
Upgrade reviewboard to a fixed version for your release line: 1.6.17 or 1.7.10.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2013-2209 being exploited?
There is no known exploitation of CVE-2013-2209 in the wild and no public exploit code.
Other vulnerabilities in n/a
Sources
Also known as GHSA-6g7x-4c7m-g63m, PYSEC-2026-913.