{"answers":{"affected":"5 open source packages ship an affected version, including reviewboard. It affects 1 product.","exploited":"There is no known exploitation of CVE-2013-2209 in the wild and no public exploit code.","fix":"Upgrade reviewboard to a fixed version for your release line: 1.6.17 or 1.7.10.","what":"CVE-2013-2209 is a medium-severity cross-site scripting vulnerability in n/a, published on 31 Jul 2013. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2013-2209 and fix it if it is affected.\n\nWhat it is: CVE-2013-2209 is a medium-severity cross-site scripting vulnerability in n/a, published on 31 Jul 2013. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2013-2209 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- reviewboard (PyPI): affected from 1.6; fixed in 1.6.17, 1.7.10\n- reviewboard (PyPI): affected from 1.6; fixed in 1.6.17\n- reviewboard (PyPI): affected from 1.6; fixed in 1.6.17\n- reviewboard (PyPI): affected from 1.7; fixed in 1.7.10\n- reviewboard (PyPI): affected from 1.7; fixed in 1.7.10\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2013-2209/ (Markdown: https://insights.sbomify.com/CVE-2013-2209/index.md)","id":"CVE-2013-2209","markdown":"https://insights.sbomify.com/CVE-2013-2209/index.md","name":"CVE-2013-2209","record":{"aliases":["GHSA-6g7x-4c7m-g63m","PYSEC-2026-913"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Review Board","requires_auth":"none","summary":"Remote attackers can inject arbitrary web script or HTML via the full name field in the auto-complete widget, potentially compromising user sessions.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"review_board","vendor":"reviewboard"}],"cvss":{"score":4.3,"severity":"medium","source":"nvd","vector":"AV:N/AC:M/Au:N/C:N/I:P/A:N","version":"2.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Cross-site scripting (XSS) vulnerability in the auto-complete widget in htdocs/media/rb/js/reviews.js in Review Board 1.6.x before 1.6.17 and 1.7.x before 1.7.10 allows remote attackers to inject arbitrary web script or HTML via a full name.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Review Board Cross-site scripting (XSS) vulnerability in the reviews dropdown","id":"CVE-2013-2209","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"xss","year":"2013"},"n_packages":5,"n_references":7,"next":{"headline":"Memory corruption in n/a","id":"CVE-2013-2210"},"packages":[{"ecosystem":"PyPI","fixed":["1.6.17","1.7.10"],"introduced":["1.6","1.7"],"last_affected":[],"package":"reviewboard","purl":"pkg:pypi/reviewboard","source":"PYSEC-2026-913"},{"ecosystem":"PyPI","fixed":["1.6.17"],"introduced":["1.6"],"last_affected":[],"package":"reviewboard","purl":null,"source":"GHSA-6g7x-4c7m-g63m"},{"ecosystem":"PyPI","fixed":["1.6.17"],"introduced":["1.6"],"last_affected":[],"package":"reviewboard","purl":"pkg:pypi/reviewboard","source":"GHSA-6g7x-4c7m-g63m"},{"ecosystem":"PyPI","fixed":["1.7.10"],"introduced":["1.7"],"last_affected":[],"package":"reviewboard","purl":null,"source":"GHSA-6g7x-4c7m-g63m"},{"ecosystem":"PyPI","fixed":["1.7.10"],"introduced":["1.7"],"last_affected":[],"package":"reviewboard","purl":"pkg:pypi/reviewboard","source":"GHSA-6g7x-4c7m-g63m"}],"prev":{"headline":"Command injection in n/a","id":"CVE-2013-2208"},"products":["n/a"],"published":"2013-07-31","related":[{"cvss_score":6.5,"headline":"Information disclosure in n/a","id":"CVE-2014-5028","kev_date_added":null,"published":"2018-03-29"},{"cvss_score":5.4,"headline":"Cross-site scripting in n/a","id":"CVE-2021-31330","kev_date_added":null,"published":"2022-05-11"},{"cvss_score":4.3,"headline":"Cross-site scripting in n/a","id":"CVE-2014-5027","kev_date_added":null,"published":"2014-07-25"},{"cvss_score":4.3,"headline":"Cross-site scripting in n/a","id":"CVE-2013-4795","kev_date_added":null,"published":"2014-04-11"},{"cvss_score":4.3,"headline":"Cross-site scripting in n/a","id":"CVE-2013-4519","kev_date_added":null,"published":"2013-11-15"},{"cvss_score":4.3,"headline":"Cross-site scripting in n/a","id":"CVE-2011-4312","kev_date_added":null,"published":"2011-11-24"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can inject arbitrary web script or HTML via the full name field in the auto-complete widget, potentially compromising user sessions.","url":"https://insights.sbomify.com/CVE-2013-2209/"}